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 1 Introduction
We are delighted that you have decided to try BOSS GNU/Linux, and are sure that you will find
that BOSS GNU/Linux distribution is unique. BOSS GNU/Linux brings together high-quality free
software from around the world, integrating it into a coherent whole. We believe that you will find
that the result is truly more than the sum of the parts. We understand that many of you want to
install BOSS GNU/Linux without reading this manual, and the Debian Installer is designed to
make this possible.

 1.1 What is BOSS GNU/Linux?
BOSS comes  with  a  set  of  features  which  are  relevant  to  primary  and  secondary  school
environment. BOSS is a GNU/Linux distribution, developed by C-DAC, to provide a complete
usable Operating System consisting of  GUIs and console applications for  routine tasks and
additional utilities which are useful for teaching/learning in schools.  

BOSS DVD pack consists of 3 sections. The Install section which gives you a BOSS Desktop in
your system, a Live section which allows you to try BOSS without installing on the Hard Disk and
without disturbing your existing OS and the Utility section which has some of the extra packages
like libreoffice, Apache web server, scripting languages etc.  You can get more details about
BOSS DVDs and their functionality in our website http://www.bosslinux.in

 1.1.1 INSTALL  

To install BOSS , you need to have a minimum of 10.0 GB of hard disk space, 512 MB of RAM
and a DVD-ROM drive. Insert the BOSS GNU/Linux DVD into the drive, restart your computer
and boot from DVD by editing the BIOS setup. The BOSS screen appears with three options:

1) Start BOSS Live

2) Install BOSS-Graphical

3) Install BOSS-Text Mode

To use BOSS Live select the “Start BOSS Live” option.

You can proceed with the default  installation by clicking  “Install  BOSS-Graphical”  or  “Install
BOSS-Text Mode”. The details about the installation options and screen shots can also be found
at BOSS GNU/Linux website http://www.bosslinux.in. 

 1.1.2 BOSS Live

BOSS Live is a GNU/Linux distribution that boots and runs completely from DVD. It includes
recent  linux  software  and  desktop  environments,  with  programs such  as  Libreoffice,  GIMP,
firefox,  Pidgin,  Totem and hundreds of  other quality  open source programs.  It  also includes
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document converter, Presentation tool, bluetooth device support and Input method for Indian
Languages. 

 1.1.3 BOSS GNU/Linux Components

1. Kernel – 3.16.0-4-686-pae

2. Firefox Web Browser

3. Pidgin Internet Messenger 

4. Libreoffice

5. BOSS Presentation Tool

6. Bulk Document Converter

7. Evolution Mail Client

8. Totem Movie Player 

9. Banshee Music Player

10. guvcview Image viewer

11. Shotwell -  Personal photo management application

12. Simple Scan - Image scanning program  

13. K3b

14. I-Bus – Intelligent Input Bus

15. Document Viewer

16. Partition Editor

17. XChat – Internet Relay Chat

18. Synaptic Package Manager

19. Remmina Remote Desktop Client

20. Transmission BitTorrent Client

 1.2 BOSS GNU/Linux Licensing
BOSS GNU/Linux is a collection of many computer programs and documents created by BOSS
Team. Each of these works might come under a different license. Our License Policy describe
the process that we follow in determining which software we will ship by default on the BOSS
Install, Live and Utility. 
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The BOSS team is committed to Free and Open Source Software. The world is a better place if
you have the source code to all the software on your computer, and the right to use that source
code in constructive ways. 

We would invite you to read more about our Free Software Philosophy and help to shape this
policy further. 

Categories of software in BOSS GNU/Linux 

We organize the thousands of software packages available for BOSS GNU/Linux into three key
components: main, contrib, non-free. Software is published in one of those components based
on whether  or  not  it  meets our  Free Software Philosophy,  and the level  of  support  we can
provide for it. This policy really addresses the software that you will find in main and non-free.
Those components contain software that is fully supported by the BOSS team and must comply
with this policy. 

All software in BOSS main and non-free must be licensed in a way that is compatible with our
license policy. There are many definitions of "free" and free software so we have included our
own set of guidelines, listed below. 

BOSS GNU/Linux "main" Component License Policy 

All application software included in the BOSS GNU/Linux main component: 

Must include source code. The main component has a strict and non-negotiable requirement
that application software included in it must come with full source code. 

Must allow modification and distribution of modified copies under the same license.
Just having the source code does not convey the same freedom as having the right to change it.
Without the ability to modify software, the BOSS community cannot support software, fix bugs,
translate it or improve it. 

 1.2.1 The BOSS Free & Open Source Software Guidelines  

1.Free Redistribution 

The license of a BOSS GNU/Linux component may not restrict any party from selling or giving
away the software as a component of an aggregate software distribution containing programs
from several different sources. The license may not require a royalty or other fee for such sale. 

2.Source Code 

The program must include source code, and must allow distribution in source code as well as
compiled form. 

3.Derived Works 

8



The license must allow modifications and derived works, and must allow them to be distributed
under the same terms as the license of the original software. 

4.Integrity of The Author's Source Code 

The license may restrict source-code from being distributed in modified form _only_ if the license
allows the distribution of  "patch files" with the source code for the purpose of  modifying the
program  at  build  time.  The  license  must  explicitly  permit  distribution  of  software  built  from
modified  source  code.  The  license  may  require  derived  works  to  carry  a  different  name or
version number from the original software. (This is a compromise. The BOSS group encourages
all authors not to restrict any files, source or binary, from being modified.)

5.No Discrimination Against Persons or Groups 

The license must not discriminate against any person or group of persons. 

6.No Discrimination Against Fields of Endeavor 

The license must  not  restrict  anyone from making  use of  the program in  a  specific  field  of
endeavor. For example, it may not restrict the program from being used in a business, or from
being used for genetic research. 

7.Distribution of License 

The rights  attached to the program must  apply  to  all  to  whom the program is  redistributed
without the need for execution of an additional license by those parties. 

8.License Must Not Be Specific to BOSS GNU/Linux 

The rights attached to the program must not depend on the program's being part of a BOSS
GNU/Linux system. If the program is extracted from BOSS GNU/Linux and used or distributed
without BOSS GNU/Linux but otherwise within the terms of the program's license, all parties to
whom the program is redistributed should have the same rights as those that are granted in
conjunction with the BOSS system. 

9.License Must Not Contaminate Other Software 

The  license  must  not  place  restrictions  on  other  software  that  is  distributed  along  with  the
licensed software. For example, the license must not insist that all other programs distributed on
the same medium must be free software. 

10.Example Licenses 

The "GPL", "BSD", and "Artistic" licenses are examples of licenses that we consider "free".

9



 2 Installation Steps
This manual helps you to install BOSS GNU/Linux on desktops and laptops. The installation
system is flexible enough to use even if you have no previous knowledge of Linux or computer
networks.  If  you  select  default  options,  BOSS  GNU/Linux  provides  a  complete  desktop
operating system, including productivity applications, Internet utilities, and desktop tools. 

This document  does not  detail  all  of  the features of  the installation system.  If  you want  the
complete  details  of  the  features  during  installation  please  check  our  BOSS  website  at
http://www.bosslinux.in

 2.1 Before You Begin

 2.1.1 System Requirements

BOSS GNU/Linux does not  impose hardware requirements  beyond the requirements  of  the
Linux kernel and the GNU tool-sets. Therefore, any architecture or platform to which the Linux
kernel, libc, gcc, etc. have been ported, can run BOSS GNU/Linux. To install BOSS GNU/Linux
you need very minimum system configurations. The hardware requirement details are as follows:
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 Hard Disk – 10.0 GB (unpartitioned space)

 RAM – 512 MB 

 DVD-ROM drive

To  install  BOSS  GNU/Linux  from  disc,  you  need  the  installation  DVD,   currently,  BOSS
GNU/Linux  supports  the  i386,  ppc,  and  x86_64 architectures.  These  architectures  are
described below: 

i386

Intel  x86-compatible  processors,  including  Intel  Pentium  and  Pentium-MMX,  Pentium  Pro,
Pentium-II,  Pentium-III,  Celeron,  Pentium 4,  and Xeon;  VIAC3/C3-m and Eden/Eden-N; and
AMD Athlon, AthlonXP, Duron, AthlonMP, and Sempron 

x86_64

64-bit AMD processors such as Athlon64, Turion64, Opteron; and Intel 64-bit processors such
as EM64T 

 2.1.2 Overview of the Installation Process

First, just a note about re-installations. With BOSS GNU/Linux, a circumstance that will require a
complete re-installation of your system is very rare; perhaps mechanical failure of the hard disk
would be the most common case. Many common operating systems may require a complete
installation to be performed when critical failures take place or for upgrades to new OS versions.
Even if  a completely new installation isn't  required, often the programs you use must be re-
installed to operate properly in the new OS. Under BOSS GNU/Linux, it is much more likely that
your OS can be repaired rather than replaced if  things go wrong. Upgrades never require a
wholesale installation; you can always upgrade in-place. And the programs are almost always
compatible with successive OS releases. If a new program version requires newer supporting
software, the BOSS packaging system ensures that all the necessary software is automatically
identified and installed. The point is, much effort has been put into avoiding the need for re-
installation, so think of it as your very last option. The installer is not designed to re-install over
an existing system. Here's a road map for the steps you will take during the installation process. 

1. Back up any existing data or documents on the hard disk where you plan to install.

2. Gather information about your computer and any needed documentation, before starting
the installation. 

3. Create partition-table space for BOSS on your hard disk.

4. Set up the first boot drive to DVD drive (through CMOS setup) and restart your system. 

5. Insert the BOSS GNU/Linux DVD into the drive

6. Boot the installation system. 

7. Select installation language. 

8. Activate the ethernet network connection, if available. 
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9. Create and mount the partitions on which BOSS GNU/Linux will be installed. 

10. Watch the automatic install/setup of the base system. 

11. Installs additional software (tasks and/or packages), at your discretion.

12. Installs a boot loader which can start up BOSS GNU/Linux on your existing system.

13. Load the newly installed system for the first time, and make some initial system settings.

14. If you have problems during the installation, it helps to know which packages are involved
in which steps. 

15. Introducing the leading software actors in this installation drama: The installer software,
debian-installer,  is the primary concern of this manual. It  detects hardware and loads
appropriate  drivers,  uses  dhcp-client  to  set  up  the  network  connection,  and  runs
debootstrap to install the base system packages. Many more actors play smaller parts in
this process, but debian-installer has completed its task when you load the new system
for  the first  time.  Upon loading the new base system, base-config supervises adding
users, setting a time zone (via tzsetup), and setting up the package installation system
(using apt-setup). It then launches tasksel which can be used to select large groups of
related programs, and in turn can run aptitude which allows you to choose individual
software packages. 

 2.1.3 Back Up Your Existing Data!

Before you start, make sure to back up every file that is now on your system. If this is the first
time a non-native operating system has been installed on your computer, it's quite likely you will
need to re-partition your disk to make room for BOSS GNU/Linux. Anytime you partition your
disk, you should count on losing everything on the disk, no matter what program you use to do it.
The programs used in installation are quite reliable and most have seen years of use; but they
are also quite powerful and a false move can cost you. 

Even after backing up be careful and think about your answers and actions. Two minutes of
thinking can save hours of unnecessary work. If you are creating a multi-boot system, make sure
that you have the distribution media of any other present operating systems on hand. Especially
if you repartition your boot drive, you might find that you have to reinstall your operating system's
boot loader, or in many cases the whole operating system itself  and all  files on the affected
partitions.

 2.2 Beginning the Installation
To begin installation of BOSS GNU/Linux, boot the computer from the boot media i.e from CD or
DVD or any other storage bootable media like USB . 

The BIOS (Basic Input/Output System) on your computer must support the type of boot media
you  select.  The  BIOS  controls  access  to  some  hardware  devices  during  boot  time.  Any
computer that meets the minimum recommended specification for BOSS GNU/Linux can boot
from a CD or DVD drive with the first disc.
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If you are not sure what capabilities your computer has, or how to configure the BIOS, consult
the  documentation  provided  by  the  manufacturer.  Detailed  information  on  hardware
specifications and configuration is beyond the scope of this document. 

Aborting the Installation

To abort  the installation process at  any time before the  Installing Packages screen, either
press Ctrl+Alt+Del or power off the computer with the power switch. BOSS GNU/Linux makes
no changes to your computer until package installation begins. Booting from Disc

To boot your computer from disc: 

1. Switch on the computer.

2. Insert the  disc into the DVD drive.

3. A screen appears to ask for a  booting option., 

1) Start BOSS Live

2) Install BOSS-Graphical

3) Install BOSS-Text Mode  

4) Advance options

5) Help

1. Booting through “Start BOSS Live”  will take you a tour around BOSS virtually. Using this
Live Boot you can check out the BOSS desktop and its applications and once you are
satisfied with BOSS., you can come back and choose for “Install BOSS-Graphical” or
“Install BOSS-Text Mode”.
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Figure 1. Boot Screen

 2.3 Language Selection
The installation program displays a list of languages which are supported by BOSS GNU/Linux.
Select the Language as “English” / “Tamil” / “Hindi” (or any other). Click “Continue” to proceed.

 Figure 2. Language Selection Screen

 2.4 Country Selection 
Next the country selection screen appears. Select the appropriate country from the list.  Click
“Continue” and proceed further    
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  Figure 3. Country Selection Screen

 2.5 Keyboard Configuration
The installation program displays a list of the keyboard layouts supported by BOSS GNU/Linux.
Highlight the correct layout on the list, and select “Next”. 

                                    Figure 4. Keyboard Configuration Screen

 2.6 Network Configuration
Configuring Network Automatically

If you have a DHCP Server, then the Network will be automatically configured. There is no need
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for the user to bother about the network configuration. 

Configuring Network Manually

If that is not the case, you need to manually configure the network. When the DHCP server is not
available, the following screen appears which means you need to configure manually.

 Figure 5.1 Network Configuration

Click on “Continue” to proceed towards Manual Network configuration.
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Figure 5.2 Network Configuration 

Select “Configure Network Manually” and set the IP address and configure network.

Figure 5.3 Network Configuration
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The screen shots are as follows:

Figure 5.4 Network Configuration

             Figure 5.5 Network Configuration

The next screen will ask you to enter the hostname for the system.
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 2.7 Disk Partitioning Setup
If you are new to Linux, you may want to use the automatic partitioning method. If you are a more
experienced Linux user, use the manual partitioning method for more control over your system
configuration, or select and modify the automatically defined partitions.

The screen below shows the way you would like to partition. These are the following ways in
which you can partition the hard disk

a) Automatic partitioning

b) LVM partitioning

c) Manual partitioning.

a) Automatic Partitioning

By selecting automatic partitioning, you will not have to use partitioning tools to assign mount 
points, create partitions or allocate space for your installation. 

You will be provided with two options in automatic partition - 

 Format entire Hard Disk

 Use Existing Hard disk Space

           Figure 6.1 Format Entire Hard Disk
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           Figure 6.2 Use the largest Free Space Available

Figure 6.3 Allot the space for different directories
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b) LVM partitioning

LVM is a tool for logical volume management which includes allocating disks, resizing logical
volumes.  The Logical Volume Manager (LVM) enables flexible distribution of hard disk space
over several file systems. As it is difficult to modify partitions on a running system, LVM was
developed. It provides a virtual pool (Volume Group — VG for short) of memory space from
which logical volumes (LV) can be generated if needed. The operating system accesses these
instead of the physical partitions. 

The screen shots are as follows:

                                                  Figure 6.4 LVM Partitioning 
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                                Figure 6.5 Select the disk to partition

                              Figure 6.6 LVM Partitioning

22



Figure 6.7 Finish Partitioning

Figure 6.8 LVM Partitioning
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Figure 6.9 LVM Partitioning

Use Existing Hard disk Space

This means that you need to have an empty unpartitioned free space which is not used for any
other OS like Windows or Linux. Once you select this option it will ask you for the partition space
details and then format it, later the installation proceeds. 

c) Manual Partitioning

Creating a new partition

To partition manually , the following screen shots will help you setting up the partition.

1. A screen with name “Partition disks” will be displayed. In that click “Manual” and then 
click “Continue.”
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2. After clicking “Manual” a screen will  be displayed which contains overview of your 
currently configured partitions. Click on free space and then click “Continue”.
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3. Create new partition for BOSS GNU/Linux by double clicking “Create a new partition”

   

4. A screen appears showing the maximum size that can be assigned for this partition. 

In this screen change the size to your required size. The minimum should be 5.0 GB.

26



Then click “Continue”.

5. Select the type for the new partition. 

6. Specify whether the partition should be at the beginning or at the End.

27



7. Click “Done setting up the partition” and then click “Continue”.
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After selecting the partition for the “/”, you need to select a partition for the “swap” space.  If you 
are already having Linux installed on your system then you will be having a swap space in your 
system. If so no need of another swap space. The swap should be double the  RAM size. If there
is no swap space then create a new swap space. The screen shots are as follows:

8. Create a swap area of 1 GB from free space.

9. Click “Create a new partition” and then click “Continue”.

10. Specify the partition size for swap area as 1.0 GB.
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11. Select the type for the new partition.

12. Specify whether the partition should be at the beginning or at the End.
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13. Change default file system ext4 to swap by double clicking “Ext4 journaling file system” in
the screen shown below.

14. Double click “swap area”. 

15. Creation of swap area is completed. Click “Done setting up the partition” and then click 
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“Continue”

16. Finish the partitioning process.
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17. Write the changes to disk by clicking “Yes”.

Deleting the hard disk partition

To partition manually , the following screen shots will help you setting up the partitioning 
separately for “/” and “swap”.

1. A screen with name “Partition disks” will be displayed. In that click on “Manual” and then 
click on “Continue.”

2. After  clicking  “Manual”  a  screen will   be  displayed which  contains  overview of  your
currently configured partitions and mount points.

Then click on partition which you want to delete and then click “Continue”.
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3. Click on “Delete the partition” and then click “Continue”.

4. Once that partition is deleted you will get some free space.

34



5. To create a new partition using that free space double-click on “Create a new partition”.
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6. In the next screen specify the new partition size. The minimum size should be 10.0GB.     

7. Select the type for the new partition.
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8. Specify whether the partition should be at the beginning or at the End.

9. Click “Done setting up the partition” and then click “Continue”.
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After selecting the partition for the “/”, you need to select a partition for the “swap” space.  If you
are already having Linux installed on your system then you will be having a swap space in your
system. If so no need of another swap space. The swap should be double the  RAM size. If there
is no swap then create a new swap space. The screen shots are as follows:

10. Create swap area of 1GB from free space

11. Create new swap area by double clicking “Create a new partition”.
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12. Specify the partition size for swap area as 1.0 GB.

13. Select the type for the new partition. 

14. Specify whether the partition should be at the beginning or at the End.
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15. Change default file system ext3 to swap by double clicking “Ext3 journaling file system” in
the screen shown below.

16. Double click on “swap area”.
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17. Creation of swap area is completed. Click on “Done setting up the partition”  and then 
click “Continue”

18. Finish the partitioning process.
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19. After all the partitions are allocated, you need to write the changes to disk. For this select
“Yes” in in the following screen and then click “Continue”. 

Resizing the Hard disk Partition

To resize hard disk partition at the time of installing BOSS GNU/Linux, follow these steps:

1. A screen with name “Partition disks” will be displayed. In that click “Manual” and then
click “Continue.”
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2. After  clicking  “Manual”  a  screen will   be  displayed which  contains  overview of  your
currently configured partitions and mount points. Then click on the partition which you
want to resize and then click “Continue”.

3. Double click on “Resize the partition”.
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4. It will ask the confirmation before writing the changes to disk. Click “Yes” and then click
“Continue”.

5. This screen will show by default maximum size as a new partition size which you can 
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change as per requirement. You can give new partition size more than whatever required 
to that particular file system then click “Continue”.

6. Now you have done resizing. You will get some free space to install BOSS GNU/Linux.
Click on free space.
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7. Create new partition for BOSS GNU/Linux by clicking “Create a new partition”.

8. Give partition size for installing BOSS GNU/Linux. It should be minimum 5.0 GB.

9. Select the type of partition.
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10. Specify whether the partition should be at the beginning or end.   

11. Partition setting is covered. Click “Done setting up the partition” and click “Continue”.
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After selecting the partition for the “/”, you need to select a partition for the “swap” space.  If you
are already having Linux installed on your system then you will be having a swap space in your
system. If so no need of another swap space. The swap should be double the  RAM size. If there
is no swap then create a new swap space by following the steps 8 to 15 in “Creating a new
partition” section.

12. Finish the partitioning process.

13. After all the partitions are allocated, you need to write the changes to disk. For this select
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“Yes” in in the following screen and then click “Continue”. 

 2.8 Installing the Base System
BOSS GNU/Linux is ready to install the packages into your system now.  

 2.9 Create User Account 
Next step is to create a user account and setting password for the user. You can use this user
account for logging into BOSS GNU/Linux. And this user will be used for auto login to BOSS
GNU/Linux after certain time period. 
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The screen shots are as follows:

Figure 8. Set up user account
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Figure 8.1 Set up user account's username

Figure 8.2 Set up user account's password
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 2.10 GRUB Installation
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Once the installation process gets completed, the system restarts automatically. 

 3 GNOME Desktop
GNOME is a Graphical User Interface that has many applications designed to help you in your
daily work.
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 3.1 Logging In and Selecting a Desktop
To start a normal login, just enter your username and password.

System

Performs a system action, such as shutting down the computer or starting different login actions.

 3.1.1 Locking Your Screen

To lock the screen use the keyboard shortcut Ctrl+ Alt+L.

 3.2 Logging Out
When you are finished using the computer, you can log out and leave the system running or
restart or shut down the computer. If your system provides power management, you can also
suspend the computer, making the next system start much faster than a complete boot.

To log out and leave the system running, do one of the following:

Select System -> Log Out....

Use the keyboard shortcut that is defined in the GNOME keyboard shortcuts. Usually, to log out
with confirmation, this is Ctrl+Alt+Del. 

 3.3 Desktop Components
The main components of the desktop are the icons on the desktop and the panel at the top and
bottom of the screen.
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 3.3.1 Desktop Icons

The desktop has the following icons by default:

Trash 

Contains files and folders that have been deleted. 

Computer

Displays information about hardware, network status, operating system, hard disks, common
folders, and removable devices.

Home

Displays the files and folders in the home folder.

 3.3.2 Panel

The panel is a bar, typically located at the top and bottom of the screen. It is designed to provide
information about running applications or the system and easy access to some applications. If
you hold your pointer over an icon on the panel, a short description is displayed.

Top Panel

The top panel typically consists of the following items:

55



Menu Bar

By default, Menu Bar appears at the left end of the panel. The Menu Bar has a well-ordered
structure for accessing the main applications. It also contains menu items for major functions
like logging out or searching for applications. 

The following icons by default appears in the right side of the top panel

Notification Area

The notification icons like Update Manager, SCIM appears in the notification area.

Clock

The clock icon displays the current date and time.

Volume Control

The Volume Control icon is useful for controlling the speaker volume.

Window Selector

This icon when clicked displays the applications running on different windows.

Bottom Panel

The bottom panel consists of the following items:

Show Desktop

This icon appears at the left side of the bottom panel. Click that icon to hide all the windows and
show the desktop.

Window List

The Window List is located next to the “Show Desktop” icon. By default, all started applications
and open windows are displayed in the Window List, which allows you to access any application
regardless of the currently active desktop. If you click a window title in the Window List, the
application is moved to the foreground. If it is already in the foreground, clicking minimizes the
application.

Workspace Switcher

By default, the right end of the bottom panel has an icon which shows your different    desktops.
These  virtual  desktops  enable  you  to  organize  your  work.  If  you  use  many     programs
simultaneously, you might want to run some programs in one desktop and other programs in the
other desktop. To switch between desktops, click the desktop symbol in the panel.

 3.4 Handling Removable Media
If you insert or connect removable media to your computer (such as CD-ROMs or USB sticks),
these are usually mounted automatically. 
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 3.4.1 Removing Media Safely

If you want to remove or disconnect a medium from your computer, make sure that the data on
the medium is currently not accessed by any application or user. Otherwise, you risk a loss of
data. 

To safely remove the medium right-click the medium to remove and select “Safely Remove” or
“Eject”. “Safely Remove” unmounts the medium after which you can disconnect the medium
from your computer. “Eject” automatically opens the CD or DVD drive of your computer.

 3.5 Managing Trash 
The trash is a directory for files marked for deletion. Drag icons from the file manager or the
desktop to the trash icon by keeping the left mouse button pressed. Then release to drop them
there. Alternatively, right-click an icon and select “Move to Trash” from the menu. Double-click
the trash icon to view its contents. You can retrieve an item from the trash if desired.

Files removed with  Shift+Delete are not  moved to the trash bin,  but deleted completely.  To
delete the files in the trash bin completely, right-click the trash bin icon then click “Empty Trash”.
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 3.6 Managing Folders and Files with Nautilus
Nautilus is a file manager. The following sections cover using Nautilus for file management. 

 3.6.1 File Manager Functionality

The Nautilus  file  manager  provides  a  simple  and  integrated  way to  manage your  files  and
applications. You can use the file manager to do the following:

Create folders and documents

Display your files and folders

Search and manage your files

Run scripts and launch applications

Customize the appearance of files and folders

Open special locations on your computer

Write data to a CD or DVD

Install and remove fonts

The file manager lets you organize your files into folders. Folders can contain files and may also
contain other folders. Using folders can help you find your files more easily.

Nautilus  also manages the desktop.  The desktop lies behind all  other  visible items on your
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screen. The desktop is an active component of the way you use your computer.

Every user has a Home Folder. The Home Folder contains all of the user's files. The desktop is
another folder. The desktop contains special icons allowing easy access to the users Home
Folder, Trash, and also removable media such as floppy disks, CDs and USB flash drives.

Nautilus  is  always  running  while  you are  using  GNOME. To  open a  new Nautilus  window,
double-click on an appropriate icon on the desktop such as “Home” or “Computer”, or choose
an item from “Places” menu on the top panel.

In GNOME many things are files, such as word processor documents, spreadsheets, photos,
movies, and music.

 3.6.2 File Manager Presentation

Nautilus provides two modes in which you can interact with your filesystem: spatial and browser
mode.  You  may  decide  which  method  you  prefer  and  set   Nautilus  to  always  use  this  by
selecting (deselecting) “Always open in browser windows” in the “Behavior” tab of the Nautilus
preferences dialog.

The following explains the difference between the two modes:

Browser mode: browse your files and folders

The file manager window represents a  browser,  which can display any location.  Opening a
folder updates the current file manager window to show the contents of the new folder.

The browser window displays a toolbar with common actions and locations, a location bar that
shows the current location in the hierarchy of folders, and a sidebar that can hold different kinds
of information.

In Browser Mode, you typically have fewer file manager windows open at a time. 

Spatial mode: navigate your files and folders as objects 

The file manager window represents a particular folder. Opening a folder opens the new window
for that folder. Each time you open a particular folder, you will find its window displayed in the
same place on the screen and the same size as the last time you viewed it (this is the reason for
the name 'spatial mode').

Using spatial mode may lead to more open file manager windows on the screen. 

59



 3.6.3 File Browser Window Components

The nautilus file browser window consists of the following elements:

Menu Bar

You can also open a popup menu from file manager windows. To open this popup menu right-
click in a file manager window. The items in this menu depend on where you right-click. For
example, when you right-click on a file or folder, you can choose items related to the file or folder.
When you right-click on the background of a view pane, you can choose items related to the
display of items in the view pane.

Toolbar

Contains buttons that you use to perform tasks in the file manager.

Back - returns to the previously visited location. The adjacent drop down list also contains a list
of the most recently visited locations to allow you to return to them faster.

Forward - performs the opposite function to the “Back” toolbar item. If  you have previously
navigated back in time then this button returns you to the present.

Up - moves up one level to the parent of the current folder.

Reload - refreshes the contents of the current folder.

Home - opens your Home Folder.

Computer - opens your Computer folder.

Search - opens the search bar.
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Location Bar

The location bar is a very powerful tool for navigating your computer. 

Zoom buttons -  Enable you to change the size of items in the view pane.

View as drop-down list - Enables you to choose how to show items in your view pane.

Side Pane

Performs the following functions:

Shows information about the current file or folder. 

Enables you to navigate through your files.

To display the side pane, choose View -> Side Pane. The side pane contains a drop-down list
that enables you to choose what to show in the side pane. You can choose from the following
options:

Places - Displays places of particular interest.

Information - Displays the icon and information about the current folder. 

Tree -  Displays a  hierarchical  representation of  your  file system.  You can use the Tree to
navigate through your files.

History - Contains a history list of files, folders, FTP sites, and URIs that you have recently
visited.

Notes - Enables you to add notes to your files and folders.

Emblems - Contains emblems that you can add to a file or folder.

To close the side pane, click on the “X” button at the top right of the side pane.

 3.6.4 Searching For Files

The Nautilus file manager includes an easy and simple to use way to search for your files and
folders. To begin a search press Ctrl+F or select the “Search” toolbar button.

Enter characters present in the name or contents of the file or folder you wish to find and press
Enter. The results of your search should appear in the view pane.
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If  you are not happy with your search you can refine it by adding additional conditions. This
allows you to restrict the search to a specific file type or location. To add search conditions click
the “+” icon.
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Saving Searches

Nautilus searches can also be saved for future use. Once saved, searches may be reopened
later. 

Saved searches behave exactly like regular folders, for example you can open, move or delete
files from within a saved search.

 3.6.5 Using Views to Display Your Files and Folders

The file manager includes views that enable you to show the contents of your folders in  different
ways, icon view, and list view.

Icon view - Shows the items in the folder as icons.

List view - Shows the items in the folder as a list.

 3.6.6 Moving a File or Folder

You  can  move  a  file  or  folder  by  dragging  it  with  the  mouse,  or  with  the  cut  and  paste
commands. The following sections describe these two methods.

Drag to the New Location

To drag a file or folder to a new location, perform the following steps:

1. Open two file manager windows:

The window containing the item you want to move.

The window you want to move it to, or the window containing the folder you want to move it to. 
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1. Drag the file or folder that you want to move to the new location. If the new location is a
window, drop it anywhere in the window. If the new location is a folder icon, drop the item
you are dragging on the folder.

To move the file or folder to a folder that is one level below the current location, do not open a
new window. Instead, drag the file or folder to the new location in the same window.

Cut and Paste to the new location

You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit -> Cut.

2. Open the folder to which you want to move the file or folder, then choose Edit -> Paste. 

 3.6.7 Copying a File or Folder

You  can  copy  a  file  or  folder  by  dragging  it  with  the  mouse,  or  with  the  copy  and  paste
commands. The following sections describe these two methods. 

Drag to the New Location

To copy a file or folder, perform the following steps:

1. Open two file manager windows:

The window containing the item you want to move.

The window you want to move it to, or the window containing the folder you want to move it to.

1. Drag the file or folder that you want to move to the new location. If the new location is a
window, drop it anywhere in the window. If the new location is a folder icon, drop the item
you are dragging on the folder.

To copy the file or folder to a folder that is one level below the current location, do not open a
new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to
the new location in the same window.

Copy and Paste to the New Location

You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit -> Copy.

2. Open the folder to which you want to copy the file or folder, then choose Edit -> Paste.

 3.6.8 Duplicating a File or Folder

To create a copy of a file or folder in the current folder, perform the following steps:

1. Select the file or folder that you want to duplicate.

2. Choose Edit -> Duplicate.

A copy of the file or folder appears in the current folder.               
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 3.6.9 Creating a Folder

To create a folder, perform the following steps:

1. Open the folder where you want to create the new folder.

2. Choose  File  ->  Create  Folder.  Alternatively,  right-click  on  the  background  of  the
window, then choose “Create Folder”.

An untitled folder is added to the location. The name of the folder is selected.

3. Type a name for the folder, then press Enter.

 3.6.10 Renaming a File or Folder

To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename.

2. Choose  Edit  ->  Rename.  Alternatively,  right-click  on  the  file  or  folder,  then  choose
“Rename...”.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Enter.

 3.6.11 Moving a File or Folder to Trash

To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash.

2. Choose Edit -> Move to Trash. Alternatively, right-click on the file or folder, then choose
“Move to Trash”.

Alternatively, you can drag the file or folder to the Trash object on the desktop.

When you move a file or folder from a removable media to Trash, the file or folder is stored in a
Trash  location  on  the  removable  media.  To  remove the  file  or  folder  permanently  from the
removable media, you must empty Trash.

 3.6.12 Deleting a File or Folder

When you delete a file or folder, the file or folder is not moved to Trash, but is deleted from your
filesystem immediately. The “Delete” menu item is only available if  you select the “Include a
Delete command that bypasses Trash” option in the Edit -> Preferences dialog.
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To delete a file or folder perform the following steps:

1. Select the file or folder that you want to delete.

2. Choose  Edit  ->  Delete.  Alternatively,  right-click  on  the  file  or  folder,  then  choose
“Delete”.

Alternatively, select the file or folder you want to delete, and press Shift+Del

 3.6.13 Creating a Symbolic Link to a File or Folder              

A symbolic link is a special type of file that points to another file or folder. When you perform an
action on a symbolic link, the action is performed on the file or folder to which the symbolic link
points. However, when you delete a symbolic link, you delete the link file, not the file to which the
symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want to create a
link. Choose Edit -> Make Link. A link to the file or folder is added to the current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold  Ctrl+Shift.
Drag the item to the location where you want to place the link.

By default, the file manager adds an emblem to symbolic links.

The permissions of a symbolic link are determined by the file or folder to which a symbolic link
points.

 3.6.14 File Permissions

Permissions are settings assigned to each file and folder that determine what type of access
users can have to the file or folder. For example, you can determine whether other users can
read and edit a file that belongs to you, or only have access to read it but not make changes to it.

Each file belongs to a particular user, and is associated with a group that the owner belongs to.
The super user "root" has the ability to access any file on the system.

You can set permissions for three categories of users:

Owner - The user that created the file or folder.

Group - A group of users to which the owner belongs.

Others - All other users not already included.

For each category of user, different permissions can be set. These behave differently for files
and folders, as follows:

read

Files can be opened
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Directory contents can be displayed

write

Files can be edited or deleted

Directory contents can be modified

execute

Executable files can be run as a program

Directories can be entered

 3.6.15 Changing Permissions

Changing Permissions for a File

To change the permissions of a file, perform the following steps:

1. Select the file that you want to change. 

2. Choose File -> Properties. The properties window for the item is displayed.

3. Click on the “Permissions” tab.

4. To change the file's group, choose from the groups the user belongs to in the drop-down
selector.

5. For each of the owner, the group, and all other users, choose from these permissions for
the file:

None - No access to the file is possible(You can't set this for the owner).

         Read-only - The users can open a file to see its contents, but not make any  changes.

Read and Write - Normal access to a file is possible: it can be opened and saved.

6. To allow a file to be run as a program, select “Execute”

Changing Permissions for a Folder

To change the permissions of a folder, perform the following steps:

1. Select the folder that you want to change. 

2. Choose File -> Properties. The properties window for the item is displayed.

3. Click on the “Permissions” tab.

4. To change the folder's group, choose from the groups the user belongs to in the drop-
down selector.

5. For each of the owner, the group, and all other users, choose from these folder access
permissions:

None - No access to the folder is possible (You can't set this for the owner.)
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List files only - The users can see the items in the folder, but not open any of them.

Access  files  -  Items  in  the  folder  can  be  opened  and  modified,  provided  their  own  
permissions allow it.

Create and delete files - The user can create new files and delete files in the folder,
in addition to being able to access existing files.

To set permissions for all the items contained in a folder, set the “File Access” and “Execute”
properties and click on “Apply permissions to enclosed files”.

 3.6.16 Writing CDs or DVDs

Writing to a CD or DVD may be useful for backing up your important documents. To do this, your
computer must have a CD or DVD writer. 

A simple way to check what sort of CD or DVD drive your computer has is to choose Places ->
Computer from the top panel menubar. If the icon for your CD drive has terms like "CD-RW" or
"DVD(+-)R" in its label, then your computer is able to write discs.

You can start choosing files to burn to a disc at any time. The file manager provides a special
folder for files and folders that you wish to write to a CD or DVD. From there you can easily write
all of the content (which you place in this special folder) to a CD or DVD.

Creating Data Discs

To write a CD or DVD, perform the following steps:

1. Choose  Places  ->  CD/DVD Creator.  The  file  manager  opens  the  CD/DVD  Creator
folder.

In a File Browser window, this item is in the Go menu.

2. Drag the files and folders that you want to write to CD or DVD to the CD/DVD Creator
folder.

3. Insert a writable CD or DVD into the CD/DVD writer device on your system.

4. Press the “Write to Disc” button, or choose File -> Write to CD/DVD. A Write to Disc
dialog is displayed.

5. Use the Write to Disc dialog to specify how you want to write the CD

Write disc to - Select the device to which you want to write the CD from the drop-down list. To
create a CD image file, select  the “File image” option.  A CD image file is a normal file that
contains all of the data in the same format as a CD, that you can write to a CD later.

Disc name - Type a name for the CD in the text box.

Data size - Shows the size of the data to be written to disc. The blank disk must be at least this
size.

Write speed - Select the speed at which you want to write the CD from the  drop- down list.

Click on the “Write” button. 
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If you selected the “File image” option from the “Write disc to” drop-down list,  “Choose a
filename for the disc image” dialog is displayed. Use the dialog to specify the location
where you want to save the disc image file. By default, disc image files have a .iso file
extension.

A Writing disc dialog is  displayed.  This process takes some time.  When the disc is  
written  or  when  the  disc  image  file  is  created,  a  message  to  indicate  that  the  
process is complete is displayed in the dialog.

Copying CDs or DVDs

You can create a copy of a CD or DVD, either to another disc or to an image file stored on your
computer. To create a copy, perform the following steps:

1. Insert the disc you want to copy.

2. Choose Places -> Computer from the top panel menubar.

3. Right-click on the CD icon, and choose “Copy Disc”.

4. The Write to Disc dialog is displayed.

If you have only one drive with write capabilities, the process will first create a disc image file on
your computer. It will then eject the original disk, and ask you to change it for a blank disk on
which to write the copy.

Creating a Disc from an Image File

You can write a disc image to a CD or DVD. For example, you may have downloaded a disc
image from the internet, or previously created one yourself. Disc images usually have a .iso file
extension and are sometimes called iso files.

To write a disc image, right-click on the disc image file, then choose Write to Disc from the
popup menu.

 3.6.17 Accessing a Remote Server

You can use the file manager to access a remote server, be it an FTP site, a Windows share, or
an SSH server.

To access a remote server, choose  File -> Connect to Server.... You may also access this
dialog from the menu bar by choosing Places -> Connect to Server....

In the “Connect to Server” dialog, you may click on the “Browse Network” button to close this
dialog and view services available on your network in a Nautilus window.

To connect to a remote server, start by choosing the service type, then enter the server address.

If required by your server, you may provide the following optional information : 

Port - Port to connect to on the server. This should only be used if it is necessary to change the
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default port, you would normally leave this blank.

Folder - Folder to open upon connecting to server.

Name to use for connection - The designation of the connection as it will  appear in the file
manager.

If the server information is provided in the form of a URI, or you require a specialized connection,
choose “Custom Location” as the service type.

Once you have filled in the information, click “Connect” button. When the connection succeeds,
the contents of the site are displayed and you may drag and drop files to and from the remote
server.

 3.7 Finding Data on your Computer
The “Search for Files” application enables you to search for files on your system. 

To start search choose Places -> Search for Files...

 3.7.1 To Perform a Basic Search

To perform a basic search for a file on the system, perform the following steps:

1. Enter the search text in the “Name contains:” field. The search text can be a filename or
partial filename, with or without wildcards, as shown in the following table:

Name Contains Text                        Example    Result

Full or partial filename  myfile.txt Search for  Files searches for  all  files  that
contain the text myfile.txt in the filename.

Partial filename combined with
wildcards (*, [, ])

*.[ch] Searches for all files that have extension .c
or .h

2. In the “Look in folder:” field, select the folder or device from which you want Search for
Files to begin the search.

3. Click “Find” to perform the search.

Search for Files searches in the directory that you specify and the subdirectories of the directory.
Search for Files displays the results of the search in the Search results list  box. If Search for
Files does not find any files that match the search criteria, the application displays the message
"No files found" in the Search results list box. 

 3.7.2 To Add Search Options

You can add additional  options to  search for  a  file  on the system.  To add search options,
perform the following steps:

1. Click on the “Select more options” text. 

2. Click on the “Available options:” drop-down list.
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3. Select the search option that you want to apply.

4. Click “Add”.

5. Specify the required search information for the search option

6. Repeat the above steps for each search option that you want to apply.

To remove a search option from the current search, click on the “Remove” button next to the
option.

To disable the search options from the current search, click on the “Select more options” text.

 3.7.3 To Stop a Search

Click “Stop” to stop a search before Search for Files completes the search.

 3.7.4 To Open a Displayed File

To open a file displayed in the Search results list box, perform one of the following steps:

Right-click on the file, then choose “Open”.

Double-click on the file.

To open the folder that contains a file displayed in the Search results list box, right-click on the
file, then choose “Open Folder”.

 3.7.5 To Delete a Displayed File

To delete a file displayed in the Search results list box, right-click on the file, then choose “Move
to Trash”.

 3.7.6 To Save the Search Results

To save the results of the last search that Search for Files performed, right-click in the Search
results list, then choose “Save Results As...”. Enter the name of the file to which you want to
save the results, then click “Save”.

 4 Customizing Desktop Settings
You can change the way your desktop looks and behaves to suit your own personal tastes and
needs. 

71



 4.1 Changing Individual Desktop Elements 

 4.1.1 Creating New Desktop Objects 

To create a new folder, 

1. Right-click an empty space on the desktop. 

2. From the popup menu, choose “Create Folder”.

3. An untitled folder appears on the desktop. Rename the folder.

To create a new file,

1. Right-click an empty space on the desktop. 

2. From the popup menu, choose “Create Document”. From the sub menu choose “Empty
File”. 

3. A file with name “new file”  appears on the desktop. 

To  change  the  properties,  of  the  objects  in  the  desktop  right  click  the  object  and  select
“properties”. A dialog appears with five tabs where you can change the properties of the object
such as  permissions.

 4.2 Changing the Desktop Settings
You can change a variety of settings, such as the desktop background, screen saver, fonts,
keyboard and mouse configuration, and sounds. 

 4.2.1 Changing the Desktop Background

To change the desktop background, right-click on the desktop and select “Change Desktop
Background” or choose Applications-> System Tools -> Settings and click “Background”
tab. The following window appears.
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Select the wallpaper you like and click “Select”. If you want to add wallpaper stored in another
location  click  “Pictures”  button  and select  new wallpaper  and click  “Select”.  If  you  want  to
change the background color of the desktop click “Colors” button and choose the color 
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 4.2.2 Changing the Desktop Font

To change the desktop font, choose  Applications-> System Tools -> Tweaktool and click
“Fonts” tab. A new  window appears. In that select the “Desktop font” option.

Select the font and click “OK”.

 4.2.3 Changing the Desktop Theme

To change the desktop theme choose, Applications-> System Tools -> Tweaktool and click 
the “Appearence”. The following window appears.

Select the theme you want and click “close”. 
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 5 Linux Basics with BOSS GNU/Linux
This section covers the Linux basics,  which helps you to work with BOSS GNU/Linux.  This
covers only the basics as this is not the Linux Guide. This just helps you to get startup with
BOSS GNU/Linux and help you in using for basic installation of packages and view the contents
etc.  If  you  want  to  learn  about  Linux  in  detail,  then  please  find  some  document  which  is
completely written for Linux and work with BOSS GNU/Linux. If you find any difficulty anywhere
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while using BOSS GNU/Linux, then inform us at bosslinux@cdac.in

 5.1 Opening a Shell Prompt
The desktop offers access to a shell prompt, an application that allows you to type commands
instead of using a graphical interface for all computing activities. While BOSS GNU/Linux Quick
Start Guide  primarily focuses on performing tasks using the graphical interface and graphical
tools, it is sometimes useful and faster to perform tasks from a shell prompt.

You can open a Shell prompt/Terminal by selecting Applications -> Utilities -> Terminal. 

To exit a shell prompt, click the X button on the upper right corner of the shell prompt window, or
type exit at the prompt.

 5.2 Create a  New User
During the installation process of BOSS GNU/Linux, you will be able to create one user account.
If you want to create some more user accounts after installation then you can use the Graphical
Interface for users creation else you can go with the shell prompt. First we will discuss about the
GUI method later we will discuss about the shell prompt method

To create new user account 

 Select Applications → System Tools → Settings →  Users  from the menu.
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 The following window will appear.

 Click  on Add User,  which  opens  an  interface  to  enter  details  about  the  username,
password etc. Enter all the details and click on OK. Thus the new user is added.

To create a user from shell prompt:

 Open the terminal and type adduser. 

 If  you are not logged in as root then type su to change to root user and execute the
adduser command.

 It prompts you to enter the password for the newly created user and further details. You
can skip the details if you doesn't need them. 

 5.3 Documentation for Linux Commands
If you want to learn more about the Linux commands then you can see the man pages for each
command which explains you the details about the command and its usage. Man pages of a
command are nothing but the manual pages. They can be viewed by using the man  command.
Like:

Syntax :

        $ man <command>

Example :

        $ man ls     // Displays the help page for the ls command
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 6 Networking 
Configuring Network has some simple steps to be followed:

 6.1 Networking through Ethernet
1. Go to  Applications → System  Tools  →

Settings  → Network 
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2. Select the Wired Connection

     

3. Set the IP address , Gateway etc., and click “OK”.

4. Click  the  “Apply” button.
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 6.2 Setting up Dial-up connection in BOSS
Dial-up access is a form of Internet access through which the client uses a modem connected to
a computer and a telephone line to dial into an Internet service provider’s (ISP) node to establish
a modem-to-modem link, which is then routed to the Internet.

 6.2.1 Configuring a Dial-Up Connection using wvdial & wvdialconf

Wvdial is a command-line pppd driver. It has two main components, wvdialconf and wvdial. Both
must be run as root.

Making a New Connection

1. Run  wvdialconf to  generate  a  configuration  file  containing  information  about  your
modem and ISP.

2. wvdialconf probes your com ports, looking for a modem, and determine the capabilities of
any modems it finds.

If your output looks different, check that your modem is plugged in, turned on, and connected to 
a com port.

Configuring WvDial

1. Once you have run wvdialconf, you need to edit the /etc/wvdial.conf file to reflect the 
phone number to dial, and your username and password.

2. Open up /etc/wvdial.conf in your favorite text editor. It should look something like this:

[Dialer Defaults]
Modem = /dev/ttyS1
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
; Phone = 555-1212
; Username = my_login_name
; Password = my_login_password

3. Remove the ';' in front of the Phone, Username and Password lines
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4. Fill ISP phone number on the Phone = line.

5. Fill your Username on the Username = line. 

6. Fill your Password on the Password = line. 

7. Save your changes and exit out of the text editor.

Connecting to the Internet

Run wvdial command in terminal. Assuming that you filled in your phone number, username, 
and password correctly, wvdial will now dial your ISP.

Disconnecting from the Internet

wvdial will not exit until the connection is terminated- you can do a Ctrl+C to terminate it.

 6.3 Setting up Broadband Internet connection 
in BOSS
If your ISP assigned a username and password to use when you connect to your broadband
Internet connection, then you must set up PPPoE before you can connect to the Internet. Click
Applications → System  Tools  →  ADSL/PPPOE  Configuration.  This  application  will
attempt to detect PPPoE use on your network, and then enter your username and password to
connect to the ISP. 

If there is any previous connection make the required modifications. 

Normally the "Use Peer DNS" and "Limited MSS problem" are set YES 
If you want your internet connection to be set up every time you login.,then give YES for Startup
option. 
Set the connection immediately and enjoy surfing in BOSS. 

If you don't want to go for a startup option, then you can start the connection manually everytime 
on demand through terminal by using the following command:

sudo pon dsl-provider 

To stop the ADSL connection type
sudo poff dsl-provider 

Later in case if you want to set up the connection everytime in startup.,ie at booting time.,
sudo gedit /etc/network/interfaces 

and add the below lines to the file
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf 
auto dsl-provider
iface dsl-provider inet ppp
provider dsl-provider
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 6.4 Wireless Connection
To configure network click  Applications → System Tools -> Network 

Select “Wireless Connection” in the screen that appears.

Now, by default,  all  the network interfaces are not configured. The default  interface for your
wired connection is eth0, the default interface for your wireless connection is eth1, while that for
your modem should be ppp0. Click on “Wireless Connection”, and then click “Properties”.

Once you've filled your SSID (network name) and WEP key (if there is one), then you have to
make sure that you have the correct IP address. If there is no IP address, leave it on “Automatic
configuration(DHCP)” which is the default.  If  there is,  change the configuration to “Static  IP
address”, and input your IP address in the fields provided. After you've clicked “OK”, you are
ready to go.

   By clicking the network icon  in task bar in the desktop,it  shows all  the all  the available
networks including wireless,wired connections. Following screen shot show these details.
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 7 Hardware Configurations

 7.1 Printers
BOSS GNU/Linux contains drivers for most of the Printers, just you have to configure the printer
IP. The procedure consist of 4 steps:

Steps for Printer Configuration

1. Go to  Applications -> Sundry -> Printers Settings or  Type in terminal “system-
config-printer”
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2. Click on “Unlock” button and Enter the administrator password to unlock. Then Click the
the '+'  or  Click “Add New Printer” to add new printer.
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3. Select the the type of the printer. For Network printer enter the IP address, port no and
click “Forward”  
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4. Select the Printer Company and click “Forward” 

5. Select the Printer Model and click “Forward”.
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Configure printer specific parameters
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So, now your printer is configured successfully.

Installing Printer drivers externally if not available in BOSS GNU/Linux

If you are not able to find your printer model in the list provided then download the divers from
the following website:

http://www.linuxprinting.org/printer_list.cgi

Here you select the printer company and the model from the select box and click on “Show”.
This will follow up a page where you need to search for the Recommended Drivers line and click
on “Custom PPD” or “Download PPD” [Differs based on printer].  Save this PPD file in your
system. 

Now Select the Printing option from System –> Administration –> Printing. In the Step 2 of
configuration (figure shown below) click on “Provide PPD File”. Then click on the open folder
and select the saved PPD file. This installs your printer divers into your system.
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 7.2 USB
As soon as the USB is plugged in, it  is auto detected and can be used without any manual
mounting and configuring.

 7.3 Webcam, Digital Camera
Connect the device to your system. 

To use Webcam choose Applications -> Sound & Video -> guvcview or type guvcview in
terminal and press Enter.

If your Webcam or Digital camera drivers are not already present in BOSS GNU/Linux then you
can download them from the following link and install the drivers. The steps for installation are
mentioned in the software itself.

Links:

http://alpha.ovcam.org/ov511/cameras.html#chipsets

http://webcam.sourceforge.net/#cams

http://www.sane-project.org/sane-mfgs.html
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 7.4 Bluetooth Support
Bluetooth is an industrial specification for wireless personal area networks (PANs). Bluetooth
provides a way to connect and exchange information between devices such as mobile phones,
laptops,  PCs,  printers,  digital  cameras  and  video  game  consoles  via  a  secure,  globally
unlicensed short-range radio frequency. 

Usage of Bluetooth     

1. Transfer data from your PC to other external device(a device that supports bluetooth).

Activate bluetooth in both the PC and the external device.
Right-click on the file you want to send through bluetooth and select “Sent to...”.
A window as shown in the figure appears. In “Sent to” select the device to which you want to
transfer the file.

2.Transfer data from external device(a device that supports bluetooth) to your PC. 

 External device will detect your PC as 'BOSS-0' (scan it) 
 Send file from your device using bluetooth. 
 In your PC , Accept request from your device. 
 Data will be in your $HOME folder. 
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 8 LibreOffice
LibreOffice is a powerful office suite; its clean interface and powerful tools let you unleash your
creativity and grow your productivity. LibreOffice embeds several applications that make it the
most powerful Free & Open Source Office suite on the market: Writer, the word processor, Calc,
the  spreadsheet  application,  Impress,  the  presentation  engine,  Draw,  our  drawing  and
flowcharting  application,  Base,  our  database  and  database  front  end,  and  Math  for  editing
mathematics.

Localization

Localization involved translation of the  LibreOffice glossary having 7000 strings and resource
strings, with approximately 21000 strings. Resource strings were extracted from the built source,
translated in Hindi, and merged back with the localization tools. For localizing the source, the
Hindi  language had to be added to the build environment,  build tools,  resource system and
installation  setup  projects,  altogether  comprising  8  independent  modules  of  the  LibreOffice
source. Finally, this localized source, containing Hindi translations was then rebuilt to produce a
Hindi  localized  installation,  which  had  the  entire  user  interface  elements  (menus,  strings,
messages, tool tips, pop ups, dialog boxes and so on) in Hindi.

 8.1 The LibreOffice Application Modules 
Module               Purpose 

Writer             Word processor application module 

Calc              Spreadsheet application module 

Impress          Presentation application module 

Base                  Database application module 

Draw Application module for drawing vector graphics

Math Application module for generating  mathematical formulas

 8.2 Word Processing with Writer 
LibreOffice Writer is a full-featured word processor with page and text formatting capabilities. Its
interface is similar to interfaces for other major word processors, and it includes some features
that are usually found only in expensive desktop publishing applications. 

This section highlights a few key features of Writer. For more information about these features
and for complete instructions for using Writer, look at the LibreOffice help. 

To open writer, choose Applications -> LibreOffice ->LibreOffice Writer or 
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type libreoffice - - writer in terminal and press Enter.

Creating a New Document 

There are two ways to create a new document: 

To  create  a  document,  click  File  ->  New -> Text  Document.  Enter  text  in  the  document
window as desired. Use the “Formatting” toolbar or the “Format” menu to adjust the appearance
of the document. Use the “File” menu or the relevant buttons in the toolbar to print and save your
document. With the options under “Insert”, add extra items to your document, such as a table,
picture, or chart.

Opening the Styles and Formatting Window 

The Styles  and  Formatting  window is  a  versatile  formatting  tool  for  applying  styles  to  text,
paragraphs,  pages,  frames,  and  lists.  To  open  this  window,  click  Format  ->  Styles  and
Formatting. LibreOffice comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles. 

Applying a Style 
To apply a style, select the element you want to apply the style to, and then double-click the style
in the Styles and Formatting window. For example, to apply a style to a paragraph, place the
cursor anywhere in that paragraph and double-click the desired style. 

Using Templates to Format Documents 

Most word processor users create more than one kind of document. For example, you might
write letters, memos, and reports, all of which look different and require different styles. If you
create a template for each of your document types, the styles you need for each document are
always readily available. 

Creating a template requires a little bit of up-front planning. You need to determine what you
want the document to look like so you can create the styles you need in that template. You can
always change your template, but a little planning can save you a lot of time later. 

Creating a Template 
A template is a text document containing only the styles and content that you want to appear in
every document, such as your address information and letterhead on a letter. When a document
is created or opened with the template, the styles are automatically applied to that document. 

To create a template: 

    1. Click File -> New -> Text Document. 

    2. Create the styles and content that you want to use in any document that uses this 

        template. 

    3. Click File ->Templates -> Save... 

    4. Specify a name for the template. 

    5. In the Categories box, click the category you want to place the template in. 
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        The category is the folder where the template is stored. 

    6. Click “OK”. 

To use a template, select File -> New -> Templates and Documents. Select the template you
want and add the necessary details.

Using Writer as an HTML Editor 

In addition to being a full-featured word processor, Writer also functions as an HTML editor.
Writer includes HTML tags that can be applied as you add any other style in a Writer document.
You can view the document as it will appear online, or you can directly edit the HTML code. 

Creating an HTML Document 

    1. Click File -> New -> HTML Document. 

    2. Click the arrow at the bottom of the Styles and Formatting window. 

    3. Select HTML Styles. 

    4. Create your HTML document, using the styles to tag your text. 

    5. Click File -> Save As. 

    6. Select the location where you want to save your file, name the file, and select  

        HTML Document (.html) from the Filter list. 

     7. Click “OK”.

If you prefer to edit HTML code directly, or if you want to see the HTML code created when you
edited the HTML file as a Writer document, click  View -> HTML Source.  In HTML Source
mode, the Formatting and Styles list is no longer available. 

 8.3 Using Spreadsheets with Calc
Calc is the LibreOffice spreadsheet application. To open calc choose Applications  -> Office -
> LibreOffice.org  Calc or type libreoffice - -calc in terminal and press Enter. 

To create a new spreadsheet click File -> New -> Spreadsheet. To open an already existing
file click File -> Open. 

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data from other
cells to generate a value for the cell in which it is inserted. You can also create charts from cell
values.

Using Formatting and Styles in Calc 

Calc  comes  with  a  few  built-in  cell  and  page  styles  to  improve  the  appearance  of  your
spreadsheets and reports. Although these built-in styles are adequate for many uses, you will
probably find it useful to create styles for your own frequently used formatting preferences. 
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Creating a Style 

1. Click Format -> Styles and Formatting. 

2. In the Styles and Formatting window, click either the “Cell Styles” or the “Page Styles”
icon.

3. Right-click in the Styles and Formatting window, then click “New...”.

4. Specify a name for  your style and use the various tabs to set  the desired formatting
options.

5. Click “OK”.

Modifying a Style 

1. Click Format -> Styles and Formatting. 

2. In the Formatting and Styles window, click either the “Cell Styles” or the “Page Styles”
icon. 

3. Right-click the name of the style you want to change, then click “Modify...”. 

4. Change the desired formatting options. 

5. Click “OK”. 

Using Templates in Calc 

If you use different styles for different types of spreadsheets, you can use templates to save your
styles for each spreadsheet type. Then, when you create a particular type of spreadsheet, open
the applicable template and the styles you need for that template are available in the Styles and
Formatting window. 

Creating a Template 
A Calc template is a spreadsheet that contains styles and content that you want to appear in
every spreadsheet created with that template, such as headings or other cell styles. When a
spreadsheet is created or opened with the template, the styles are automatically applied to that
spreadsheet. 

To create a template: 

1. Click File -> New -> Spreadsheet. 

2. Create the styles and content that you want to use in any spreadsheet that uses this
template.

3. Click File -> Templates -> Save. 

4. Specify a name for the template. 
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5. In the Categories box, click the category you want to place the template in. 

The category is the folder where the template is stored. 

6. Click “OK”.

To use the template in your document select File -> New -> Templates and Documents and
select the name of the template you want to use. 

 8.4 Using Presentations with Impress
Use LibreOffice Impress to create presentations for screen display or printing, such as slide
shows  or  transparencies.  If  you  have  used  other  presentation  software,  you  can  move
comfortably to Impress, which works very similarly to other presentation software. Impress can
open  and  save  Microsoft  PowerPoint  presentations,  which  means  you  can  exchange
presentations with PowerPoint  users, as long as you save your presentations in PowerPoint
format.

To open presentation,  choose  Applications -> Office -> LibreOffice 3.2 Impress  or type
libreoffice  - -impress in terminal and press Enter.

Creating a Presentation 

To create a new presentation, click File -> New -> Presentation. Select the option to use for
creating the presentation.

There are two ways to create a presentation:

1. Create an empty presentation 

Opens Impress with a blank slide. Use this option to create a new presentation from scratch,
without any preformatted slides. 

2. Create a presentation from a template 

Opens Impress with your choice of template. Use this option to create a new presentation with a
predesigned LibreOffice template or a template you’ve created or installed yourself, such as your
company’s  presentation  template.  Impress  uses  styles  and  templates  the  same  way  other
LibreOffice modules do. 

Using Master Pages 

Master pages give your presentation a consistent look by defining the way each slide looks,
what fonts are used, and other graphical elements. Impress uses two types of master pages:

1. Slide master 

Contains elements that appear on all slides. For example, you might want your company logo to
appear in the same place on every slide. The slide master also determines the text formatting
style for  the heading and outline of  every slide that  uses that  master  page,  as well  as any
information you want to appear in a header or footer. 
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2. Notes master 

Determines the formatting and appearance of the notes in your presentation. 

Creating a Slide Master 

Impress comes with a collection of preformatted master pages. Eventually, most users will want
to customize their presentations by creating their own slide masters. 

    1. Start Impress, then create a new empty presentation. 

    2. Click View -> Master -> Slide Master. 

        This opens the current slide master in Master View. 

    3. Right-click the left-hand panel, then click “New Master”. 

    4. Edit the slide master until it has the desired look. 

    5. Click “Close Master View” or choose View -> Normal to return to Normal View. 

Applying a Slide Master 

Slide masters can be applied to selected slides or to all slides in the presentation. 

1. Open your presentation, then click View -> Master -> Slide Master. 

2. (Optional) If you want to apply the slide master to multiple slides, but not to all slides,
select the slides that you want to use that slide master.

3. To select multiple slides, in the Slides Pane, press Ctrl and click on the slides you want to
use that slide master. 

4. In the Task Pane, right-click the master page you want to apply. If you do not see the 
Task Pane, click View -> Task Pane. 

5. Apply the slide master by clicking one of the following:. 

      Apply to All Slides 

      Applies the selected slide master to all slides in the presentation. 

      Apply to Selected Slides 

Applies the selected slide master to the current slide, or to any slides you select before 
applying the slide master. For example, if you want to apply a different slide master to the 
first slide in a presentation, select that slide, then change to Master View and apply a slide 
master to that slide. 

 8.5 Using Databases with Base 
Use Base to design a database to store many different  kinds of  information,  from a simple
address book or recipe file to a sophisticated document management system. Tables, forms,
queries, and reports can be created manually or using convenient wizards. For example, the
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Table Wizard contains a number of common fields for business and personal use. Databases
created in Base can be used as data sources, such as when creating form letters. 

To open database choose, Applications -> Office -> LibreOffice Base or 

type libreoffice - -base in terminal and press Enter.

Creating a Database Using Predefined Options 

Base comes with several predefined database fields to help you create a database. The process
for creating a database can be broken into several subprocesses: 

Creating a new Database 

First, to create a new database follow these steps: 

1. Click File -> New -> Database. 

2. Select “Create a new database”, then click “Next”. 

3. Click “Yes, register the database for me” to make your database information    available
to other LibreOffice modules, select both check boxes in the bottom half of the dialog,
then click “Finish”. 

4. Browse to the directory where you want to save the database, specify a name for         the
database, then click “OK”. 

Setting Up the Database Table 

Data is stored in tables. As an example, your system address book that you use for your e-mail
addresses is a table of the address book database. Each address is a data record, presented as
a row in that table. The data records consist of data fields, for example the first and the last
name fields and the e-mail field.

Creating a New Table using the Table Wizard

1. Open the database file where you want to create the new table.

2. In the left pane of the database window, click the “Tables” icon.

3. Click “Use Wizard to Create Table”.

Creating a New Table using the Design View

1. Open the database file where you want to create the new table.

2. In the left pane of the database window, click the “Tables” icon.

3. Click “Create Table in Design View”.
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Creating a New Table View

Some database  types  support  table  views.  A  table  view is  a  query  that  is  stored  with  the
database. For most database operations, a view can be used as you would use a table.

1. Open the database file where you want to create the new table view.

2. In the left pane of the database window, click the “Tables” icon.

3. Click “Create View”.

Working with Queries 

If  you often  want  to  access only  a  subset  of  your  data  that  can be well  defined by  a  filter
condition, you can define a query. This is basically a name for the new view at the filtered data.
You open the query and see the current data in the table layout that you defined.

Creating a New Query using the Query Wizard

In LibreOffice you can create a new query using the Query Wizard:

1. Open the database file where you want to create the new query.

2. In the left pane of the database window, click the “Queries” icon.

3. Click “Use Wizard to Create Query”.

Creating a New Query using the Design View

1. Open the database file where you want to create the new query.

2. In the left pane of the database window, click the "Queries” icon.

3. Click “Create Query in Design View”.

Working with Forms 

Using forms, you can define how to present the data. Open a text document or a spreadsheet
and insert  the controls  such as push buttons and list  boxes.  In  the properties dialog of  the
controls, you can define what data the forms should display.

Creating a New Form With the Form Wizard
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In LibreOffice, you can create a new form using the Form Wizard:

1. Open the database file where you want to create the new form.

2. In the left pane of the database window, click the “Forms” icon.

3. Click “Use Wizard to Create Form”.

Creating a New Form Manually

1. Open the database file where you want to create the new form.

2. In the left pane of the database window, click the “Forms” icon.

3. Click “Create Form in Design View”.

4. A new text document opens. Use the Form controls to insert the controls into the form.

Working with Reports 

A report is a text document that either shows the current data or the data at the time the report
was created.

Creating a New Report With the Report Wizard

In LibreOffice you can create a new report using the Report Wizard.

1. Open the database file where you want to create the new report.

2. In the left pane of the database window, click the “Reports” icon.

3. Click “Use Wizard to Create Report”.
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 9 Intelligent Input Bus (IBus)

 9.1 IBus
The  Intelligent  Input  Bus (IBus,  pronounced  as  I-Bus)  is  an  input  method  (IM)

framework for multilingual input in Unix-like operating-systems

How to Configure different Keyboard using SCIM in BOSS GNU/Linux

Open Gedit/vi/LibreOffice. 

1.Press Windows Key + space to invoke toggle notification icon on task bar. 

2.It will show menu of Input Methods available in BOSS GNU/Linux. 

3.Select any language. Example Tamil. 

Three different type of keyboards are supported

i)  Phonetic Keyboard: Keyboards are widely used and it has got the English keys in it.
So, type some Indian language through this keyboard, the Indian alphabets are written
phonetically  (a  combination  of  keys  can  be  used  to  represent  one  Indian  language
character) using the English alphabets. For example, the first letter of hindi alphabet can
be written as 'ka' through English phonetic keyboard.

ii)  Inscript Keyboard : Keyboards are used which contains Indian alphabets as the key
of this keyboard. So by typing those keys the content of that language can be written.

iii) Remington Keyboard: Keyboard also contains keys of the Indian languages and the
arrangement of the keys follow the arrangement of a typewriter.

How to use I-Bus

Open  the editor  in which ever you want to type in different language, either  Text Editor or
LibreOffice.

Now  press  Windows  Key+Space  to  activate  the  languages.  You  can  see  the  languages
activated in the bottom right corner as shown below:
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Click on the window displayed like above, you will  see the languages list and the respective
keyboards supported. Select the language and keyboard support and start typing.

Supported  Languages  in  BOSS  GNU/Linux  are  Hindi,  Tamil,  Telugu,  Malayalam,  Punjabi,
Marathi, Bengali, Gujarati, and Kannada. 

Bengali Inscript Layout

Gujarati Inscript Layout
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Kannada Inscript Layout

Malayalam Inscript Layout

Tamil Inscript Layout
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Telugu Inscript Layout

 9.2 OnScreen Keyboard
OnScreen Keyboard is a utility that displays a virtual keyboard on the computer screen that
allows people with mobility impairments to type data by using a pointing device or  joystick.
Besides providing a minimum level of functionality for some people with mobility impairments,
OnScreen Keyboard can also help people who do not know how to type. On Screen Keyboard is
the other way which allows you to type in your native language and create your documentations,
mails etc. 

Usage of  the OnScreen Keyboard

1.Start the OnScreen Keyboard through  Applications -> Accessories -> OnScreen
Keyboard or type eazykeyboard in terminal and press Enter

103



2.Select the language from, “Languages” menu.

                   

           The extra letters along with the language indicate the type of keyboard layout.

R – Remington

In – Inscript

eg:  HindiR  represents  Hindi  Remington  Keyboard  and  HindiIn  represents  Hindi  
Inscript Keyboard

3.Type in different languages

Now you can open any of your favorite editor, and start typing in Hindi,Tamil, Malayalam,
Bengali, Kannada, Telugu, Punjabi, Gujarathi languages. 
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 Enjoy using OnScreen Keyboard  

 10 Internet

 10.1 Browsing with Firefox
Included  with  BOSS  is  the  Firefox  Web  browser.  With  features  like  tabs,  pop-up  window
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blocking, and download and image management, Firefox combines the latest Web technologies.
You  can  view  more  than  one  Web  page  in  a  single  window.  You  can  suppress  annoying
advertisements and disable images that only slow you down. Its easy access to different search
engines helps you find the information you need. 

To start Iceweasel choose Applications -> Internet -> Firefox Web Browser or type Firefox
in terminal and press Enter.

Firefox has much the same look and feel as other browsers. The navigation toolbar includes
Forward and Back buttons and a location bar for entering web address. Bookmarks are also
available for quick access. 

 10.1.1 Tabbed Browsing
If you often use more than one web page at a time, tabbed browsing may make it easier to
switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select  File -> New Tab. This opens an empty tab in the Firefox window.
Alternatively, right-click a link and select “Open link in New Tab”. Right-click the tab itself to
access more tab options. You can create a new tab, reload one or all existing tabs, or close
them. You can also change the sequence of  the tabs by dragging and dropping them on a
requested position.
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 10.1.2 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing history. To
display the Sidebar, select View -> Sidebar and select the desired contents.

 10.1.3 Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The search bar
looks for pages while the find bar looks for things on the current page.

 10.1.3.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or Amazon. For
example, if  you want to find information about Bharat Operating System Solutions using the
current engine, click in the search bar, type Bharat Operating System Solutions and hit Enter.
The results appears in your window. To choose your search engine, click the icon to the left of
the search bar. A menu opens with a list of available search engines.

Installing a different Search Engine

If your favorite search engine is not listed, Firefox gives you the possibility to configure it. Try the
following steps:

1.Establish an Internet connection first.

2.Click the icon to the left of the search bar.

3.Select “Manage Search Engines...” from the menu.

4.Click “Get more search engines...”.

5.Firefox  displays  a  web  page  with  available  search  engines.  You  can  choose  from
Wikipedia, IMDB, Flickr, and others. Click the desired search plug-in.

6.Install your search plug-in by clicking “Add” or abort with “Cancel”.

 10.1.3.2 Searching in the Current Page
To search inside a web page, click Edit -> Find or press Ctrl+F. The find bar opens. Usually, it
is displayed at the bottom of a window. Type your query in the input field. Firefox finds the first
occurrence of this phrase. You can find other occurrences of the phrase by pressing Ctrl+G or
“Next” button in the find bar. You can also highlight all occurrences by pressing the “Highlight
all” button. Checking the “Match case” option makes the query case sensitive.

 10.1.4 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite web sites. To add the current
web site to your list of bookmarks, click Bookmarks -> Bookmark This Page. If your browser
currently displays multiple web sites on tabs, only the URL on the currently selected tab is added
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to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and select a
folder where Firefox should store it. To bookmark web sites on multiple tabs, select “Bookmark
All Tabs...”. Firefox creates a new folder that includes bookmarks of each site displayed on each
tab. To remove a web site from the bookmarks list, click “Bookmarks”, right-click the bookmark
in the list, then click “Delete”.

 10.1.4.1 Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address location) for
each bookmark and organize the bookmarks into folders and sections. 

To open the bookmark manager, click Bookmark -> Organize Bookmarks.... A window opens
and displays your bookmarks. With Organize ->New Folder, create a new folder with a name
and a description. If you need a new bookmark, click Organize -> New Bookmark... This lets
you insert the name, location, keywords, and also a description. The keyword is a shortcut to
your bookmark.  If  you need your newly created bookmark in  the sidebar,  check “Load this
bookmark in the sidebar”.

 10.1.4.2 Importing Bookmarks from Other Browsers
If  you used a different browser in the past, you probably want to use your old bookmarks in
Firefox, too. Firefox allows to import bookmarks from other browsers installed on your system
such as Netscape or Opera. It  also allows to import  bookmarks from a file exported from a
browser on different computer.

To import your settings, click File -> Import. Select the browser from which to import settings
and click “Next”  or  choose a file.  Find your  imported bookmarks in a newly created folder,
beginning with “From”.

 10.1.4.3 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date with the
latest news. This enables you to save time with one glance at your favorite sites.

Many sites and blogs support this format. A Web site indicates this by showing an orange icon in
the  right  part  of  the  location  bar.  Click  it  and  choose  “Subscribe  to  this  feed  using  Live
Bookmarks” option. Click “Subscribe Now” in the page that opens. A dialog box opens in which
to select the name and location of your live bookmark. Confirm by clicking “Add”.

 10.1.5 Using the Download Manager
With the help of the download manager, keep track of your current and past downloads. To open
the  download  manager,  click  Tools  ->  Downloads.  Firefox  opens  a  window  with  your
downloads. While downloading a file, see a progress bar and the current file. If necessary, pause
a download and resume it  later.  To open a downloaded file, right-click on the file and click
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“Open”. To Remove, select “Remove From List”. 

If you need further control of the download manager, open the configuration window from Edit ->
Preferences and  go  to  the  Main  tab.  Here,  determine  the  download  folder  and  how  the
manager behaves.

 10.1.6 Adding Smart Keywords to Your Online Searches
Searching the Internet is one of the main tasks a browser can perform for you. Firefox lets you
define your own smart keywords: abbreviations to use as a “command” for searching the web.
For example, if you use Wikipedia often, use a smart keyword to simplify this task:

1.Go to http://en.wikipedia.org.

2.After Firefox displays the web page, see the search text field. Right-click it then choose
“Add a Keyword for this Search” from the menu that opens.

3.“Add Bookmark” dialog appears. In Name, name this web page, for example,

Wikipedia (en).

4.For Keyword, enter your abbreviation of this Web page, for example, wiki.

5.With Create in, choose the location of the entry in your bookmarks section. You

can put it into any folder.

6.Finalize with “Add”.

You have successfully generated a new keyword. Whenever you need to look into

Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an entry about
Linux.

 10.1.7 Printing from Firefox
Configure the way Firefox prints the content it displays using the “Page Setup” dialog. Click File
-> Page Setup... and select the orientation of your print jobs. You can scale or make it adjust
automatically. 

After you configured your settings, print a web page with File -> Print... Select the printer or a
file in which to save the output. Change the required settings. When satisfied with your settings,
approve with “Print”.

 10.2 Mail Client
An  e-mail client, also called a  mail user agent (MUA), is a computer program that is used to
receive and send email. Features such as storage of mails in the local system, taking backup of
the mails, filtering them into filters are all well supported by our mail client, Evolution. 
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 10.2.1 Evolution
This section briefly covers the basic steps for sending and receiving email with Evolution. 

To start Evolution, choose Applications -> Internet -> Evolution or type evolution in terminal
and press Enter.

1.You are presented with a New Account Setup screen. 

2. If user want restore from the backup file,click the option and specify the file location
otherwise click the “Next”.
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3.In  “Full  Name”  field  enter  the name you like  to  appear  in  the  “From”  field  of  your
outgoing messages.

In “Email Address” field enter your email address 

4.It will automatically connect to respective email servers if this give correct information
then click “next” otherwise “back”  to change the details of the email account and email
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server related details.

5.Enter the username given to you by the email provider for receiving mails

6.Receiving options are chose by  user for his convenience.
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7.Enter the sending mail server details and other and port details 

8.A  screen  showing  the  account  information   appears.  Click  “Apply”  to  save  these

113



settings and exit the account wizard. 

Now your account is created .

Now you can use your Evolution mail  client to view your mails and send mails with different
formatting, colors, attachments etc. You can even import your address books from the outlook
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express or any other mail client. The procedure is as simple as the account creation. 

1.Export  the address book from your mail  server into the Evolution format.  It  may
be .LDIF,.tab, .csv, txt.

2.Open the Evolution mail  client,  go to  Evolution → Contacts, which opens the
address book interface.

3.Go to Actions → Copy All Contacts To , and select locate the location from the
wizard displayed.

4.Select the file that you have just exported into your system and click “next”

5.Now all your addresses from the address book are in your Evolution.

The similar way you can take backup of addresses into a file and import in any other mail client,
which supports the specified formats.

1.Save the E-mails into your local system

You have “Local folders” in your Evolution window, which are the folders in your local system
hard disk and the content stored in these folders can be viewed when you are off-line and can

save your mails in these folders to save the mail server memory space. Create your own folder
by right clicking on the “Local Folders” and click “New Folder...”

1.Once you have your local folders ready named as per your comfort, open your inbox in
the Evolution mail client, select the mails that you want to save in the local folders (use
Ctrl key to select more than one mail) and right-click. It opens a menu, where you can see
options like “Copy To” (copies the mails to local folders) and “Move To” (deletes the
mails from the server and moves into the local folders), select that “Move To”  and then
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the target folder where you want to move the mails to.

2.Thats it, now you have your mails stored in your local system. 

2. Backup Mails and other Settings

To take the backup of your mails,address book and settings from Evolution, when you reinstall
the operating system or change your system, you have to take the backup of  the  Evolution
settings folder and paste it in the same location of the new Operating system.

Backup your Evolution email and other config files in the following way -

1.The files are stored in the .mozilla-thunderbird directory which resides in your home
directory.

2.Assuming the home directory is /home/admin.  Please replace it with your own in the
following commands -

open the terminal and execute the following commands 

[admin@spooky ~]$ tar cvfz mythund_bkp.tar.gz /home/admin/.mozilla-thunderbird/

3.The above command will create an archive named “mythund_bkp.tar.gz”

You can use  this  archive  to  restore  all  your  files  in  case  of  any  problems using  the
following command and your emails will be restored -

[admin@spooky ~]$ tar xvf mythund_bkp.tar.gz

4.Start Evolution and your emails will be in place. The advantage of the above  method is
that it not only restores emails but also your settings. So you do not  have to reconfigure
your IMAP mailboxes etc. Even your extensions are preserved.

 10.3 Empathy

Empathy is a messaging program which supports text, voice, video chat, and file transfers over
many different protocols. You can tell it about your accounts on all those services and do all your
chatting within one application. 

Empathy  uses  Telepathy  for  protocol  support  and  has  a  user  interface  based  on  Gossip.
Empathy is the default  chat client  in current versions of  GNOME, making it  easier for other
GNOME applications to integrate collaboration functionality using Telepathy. 

To login and chat with gtalk follow the below screen shots.

116



117



 10.4 Polari
Polari  is an IRC chat client designed to integrate with the GNOME desktop. Polari  supports
group chatting in chat rooms and private messaging on a wide range of popular IRC servers.

To start Polari choose Applications -> Internet -> Polari or type polari in terminal and press
Enter.

To add connection click the polari → connections → + option then give the details.
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Whether Polari is online or offline, your conversation history is always available. 
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Click the “+” option to join the room for chat.If  you know the name of the channel,  type the
channel name e.g. boss-nrcfoss 

Once you've given the name of a channel, Polari should join it for you and you can start chatting
by typing the queries in the text box at the bottom of the window.
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 10.5 Dictionary
The Dictionary application enables you to search words and terms on a dictionary source.

To start dictionary choose, Applications -> Office ->  Dictionary or type gnome-dictionary
in terminal and press Enter.

Looking up a word

To look up a word, type that word in the text box and press Enter. If some definition for the word
is found, it will appear inside the main window area.
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Saving the result of the word

To save the results of the word, choose File -> Save a Copy... 

Printing the result of the word

To print the result of the word, choose File -> Print... 

Inside the Print dialog you can select the printer to use, the paper format, the number of copies.

To see a preview of what will be printed, click “Preview”.

To print, click “Print”.

Find text

To find out a particular word from the displayed result, choose Edit -> Find. In the bottom a text
box appears. In that type the word to find.

To find the next occurrence of the text, click “Next”. 

To find the previous occurrence of the text, click “Previous”.

Dictionary Sources
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To view dictionary sources click View → Dictionary Sources

A list of available sources will be displayed. Click on the source from which you want to look up 
words.

10.6  Remmina Remote Desktop Client
Remmina is  a  remote  desktop  client  written  in  GTK+,  aiming  to  be  useful  for

system administrators and travelers, who need to work with lots of remote computers in front of
either  large monitors  or  tiny  net-books.  Remmina supports  multiple  network  protocols  in  an
integrated and consistent user interface. Currently RDP, VNC, XDMCP and SSH are supported.

To start dictionary choose, Applications -> Internet ->  Remmina Remote Desktop Client
or type remmina in terminal and press Enter.

Select the protocol to connecting to the remote system.
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VNC -Virutal Network Computing

               Select protocol VNC -Virtual Networking then select server address and enter .

Give remote desktop user name and password to connect.

10.8  Transmission
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Transmission is a BitTorrent client. It is used for peer to peer file sharing over the
Internet. BitTorrent is a fast way of transferring files, because everyone who downloads must
also upload to others. This means speeds are only limited by the number of people connected to
a given torrent - the more people the better!
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 11 Graphics

 11.1 GIMP

Main Windows

The GIMP user interface is now available in two modes:

1. multi-window mode,

2. single window mode.

When you open GIMP for the first  time, it  opens in multi-window mode by default.  You can
enable single-window mode through Windows → >Single-Window Mode) in the image menu
bar. After quitting GIMP with this option enabled, GIMP will start in single-window mode next
time.

Multi-Window Mode
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The screenshot above shows the most basic arrangement of GIMP windows that can be used
effectively.

You can notice two panels, left and right, and an image window in middle. A second image is
partially masked. The left panel collects Toolbox and Tool Options dialog together. The right
panel  collects  layers,  channels,  paths,  undo  history  dialogs  together  in  a  multi-tab  dock,
brushes, patterns and gradients dialogs together in another dock below. You can move these
panels on screen. You can also mask them using the Tab key.

1.The Main Toolbox: 

Contains a set of icon buttons used to select tools. By default, it also contains the foreground
and background colors. You can add brush, pattern, gradient and active image icons. Use Edit
→ Preferences → Toolbox to enable, or disable the extra items.

2.Tool options:

Docked below the main Toolbox is  a Tool  Options dialog,  showing options for  the currently
selected tool (in this case, the Move tool).

3.Image windows: 

Each image open in GIMP is displayed in a separate window. Many images can be open
at the same time, limited by only the system resources. Before you can do anything useful in
GIMP, you need to have at least one image window open. The image window holds the Menu
of the main commands of GIMP (File, Edit, Select...), which you can also get by right-clicking on
the window.

An image can be bigger than the image window. In that case, GIMP displays the image in
a reduced zoom level which allows to see the full image in the image window. If you turn to the
100% zoom level, scroll bars appear, allowing you to pan across the image.

4.The Layers, Channels, Paths, Undo History dock — note that the dialogs in the dock are
tabs. The Layers tab is open : it shows the layer structure of the currently active image, and
allows it  to be manipulated in a variety of ways. It  is possible to do a few very basic things
without  using  the  Layers  dialog,  but  even  moderately  sophisticated  GIMP  users  find  it
indispensable to have the Layers dialog available at all times.

5.Brushes/Patterns/Gradients:

The docked dialog below the layer dialog shows the dialogs (tabs) for managing brushes,
patterns and gradients.

Single Window Model
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You find the same elements, with differences in their management:

Left and right panels are fixed; you can't move them. But you can decrease or increase
their width. If you reduce the width of a multi-tab dock, there may be not enough place for all
tabs; then arrow-heads appear allowing you to scroll through tabs.

As in multi-window mode, you can mask these panels using the Tab key.

The image window occupies all space between both panels.

When several images are open, a new bar appears above the image window, with a tab
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for  every  image.  You  can  navigate  between  images  by  clicking  on  tabs  or  either  using
Ctrl+PageUp or PageDown or Alt+Number. “Number” is tab number; you must use the number
keys of the upper line of your keyboard, not that of keypad (Alt-shift necessary for some national
keyboards).

 11.1.1 Toolbox

By default, only the Foreground-background icon is visible. You can add Brush-Pattern-
Gradient  icons  and  Active  Image  icon  through  Edit  →  Preferences  →  Toolbox: Tools
configuration.

Tool icons: 

These icons are buttons which activate tools for a wide variety of purposes: selecting
parts of images, painting an image, transforming an image, etc.  

Foreground/Background colors:

The color areas here show you GIMP's current foreground and background colors, which
come into play in many operations. Clicking on either one of them brings up a color selector
dialog that allows you to change to a different color. Clicking on the double-headed arrow swaps
the two colors, and clicking on the small symbol in the lower left corner resets them to black and
white.

Brush/Pattern/Gradient:

 The symbols here show you GIMP'S current selections for: the Paintbrush, used by all
tools  that  allow you  to  paint  on  the  image (“painting”  includes  operations  like  erasing  and
smudging, by the way); for the Pattern, which is used in filling selected areas of an image; and
for the Gradient,  which comes into play whenever an operation requires a smoothly varying
range of colors. Clicking on any of these symbols brings up a dialog window that allows you to
change it.

Active Image: I

In GIMP, you can work with many images at once, but at any given moment, only one
image is the “active image”. Here you find a small iconic representation of the active image.
Click the icon to display a dialog with a list of the currently open images, click an image in the
dialog to make it active. Usually, you click an image window in multi-window mode, or an image
tab in single-window mode, to make it the active image.

 11.1.2 Image Window
GIMP user interface is now available in two modes: multi-window mode (default), and

single-window mode (optional,  through Windows  → >Single-Window Mode.  But,  if  you  quit
GIMP with this option enabled, GIMP will open in single mode next time).
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In single-window mode, no new window is added: images and dialogs are added in tabs.
Please see Single Window Mode.

When user start GIMP without any image open, the image window seems to be absent in
single-window mode, while, in multi-window mode, an image window exists, even if no image is
open.

User will begin with a brief description of the components that are present by default in an
ordinary image window. Some of the components can be removed by using commands in the
View menu.

Title  Bar:  The  Title  Bar  in  an  image  window  without  an  image  displays  “GNU  Image
Manipulating  Program”.  An image window with  an  image displays  the  image name and its
specifications in the title bar according to the settings in Preference Dialog. The Title Bar is
provided by the operating system, not by GIMP, so its appearance is likely to vary with the
operating system, window manager, and/or theme — in Linux systems, this title bar has a button
to display the image window on all your desktops. You also have this button in toolbox window
and layer window.

If user have opened a non-xcf image, it is “(imported)” as a .xcf file and its original name
appears in the status bar at the bottom of the image window.

When an image is modified, an asterisk appears in front of title.

Image Menu: 

Directly below the Title Bar appears the Menu bar (unless it has been suppressed). The
Image Menu provides access to nearly every operation you can perform on an image. You can
also right-click on an image to display a pop-up image menu, or by left-clicking on the little
“arrow-head” symbol in the upper left corner, called Menu Button, described just below. Many
menu commands are also associated with keyboard shortcuts as shown in the menu. You can
define  your  own custom shortcuts  for  menu  actions,  if  you  enable  Use  Dynamic  Keyboard
Shortcuts in the Preferences dialog.

Menu Button: 

Click the Menu Button to display the Image Menu in a column,(essential in full screen
mode). If you like to use keyboard shortcuts, use Shift+F10 to open the menu.

Ruler: 

In the default layout, rulers are shown above and to the left of the image. Use the rulers to
determine coordinates within the image. The default  unit for rulers is pixels; use the settings
described below to use a unit other than pixels.

One of the most important uses of rulers is to create guides. Click and drag a ruler into
the image to create a guide. A guide is a line that helps you accurately position things—or verify
that another line is truly horizontal or vertical. Click and drag a guide to move it. Drag a guide out
of the image to delete it; you can always drag another guide into the image. You can even use
multiple guides at the same time.

In ruler area, the mouse pointer position is marked with two small arrow-heads pointing
vertically and horizontally.
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QuickMask Toggle:

The small button in the lower left corner of the image toggles the Quick Mask on and off.
When the Quick Mask is on, the button is outlined in red. See QuickMask for more details on
this highly useful tool.

Pointer Coordinates: 

When  the  pointer  (mouse  cursor,  if  you  are  using  a  mouse)  is  within  the  image
boundaries,  the rectangular  area in the lower left  corner  of  the window displays the current
pointer coordinates. The units are the same as for the rulers.

Units Menu: 

Use the Units Menu to change the units used for rulers and several other purposes. The
default unit is pixels, but you can quickly change to inches, cm, or several other possibilities
using this menu. Note that the setting of “Dot for dot” in the View menu affects how the display is
scaled: see Dot for Dot for more information.

Zoom Button: 

There are a number of ways to zoom the image in or out, but the Zoom Button is perhaps
the simplest. You can directly enter a zoom level in the text box for precise control.

Status Area: 

The Status  Area is  at  the  bottom of  the image window.  By default,  the  Status  Area
displays the original name of the image.xcf file, and the amount of system memory used by the
image. Please use Edit → Preferences → Image Windows → Title & Status to customize the
information displayed in the Status Area. During time-consuming operations,  the status area
temporarily shows the running operation and how complete the operation is.

 11.2 Shotwell
To open F-Spot choose  Applications → Graphics → shotwell or type shotwell  in terminal
and press Enter.

 11.2.1 Organizing your photos

Import

To import an existing photo collection from F-Spot:

Select File ▸ Import From F-Spot.
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Now choose either  the default  F-Spot  library  or  another  F-Spot  database.  If  importing from
another F-Spot database, select a directory and file from the chooser dialog box.

Shotwell will import your photos, together with their tags and other information. Once the import
is complete, you can select Last Import in the sidebar to see all photos successfully imported.
The Events list will also show new entries for the dates corresponding to the imported photos.

Importing from Camera

Connect the camera to your computer and switch it on. Shotwell will detect it and list it in the
sidebar.

Select the camera in the sidebar. Previews of each photo on the camera will be displayed.

If you like, you can choose a set of specific photos to import. To do this, hold down the Ctrl key
and click to select individual photos. You can hold down Shift and click to select a range of
photos too.

Click either Import Selected or Import All. The photos will be copied from the camera and saved
on your computer.

Once the import is complete, you can open the Last Import view (in the sidebar) to see all photos
that  were  imported.  The  Events  list  (also  in  the  sidebar)  will  also  show  the  new  photos,
organized by date.

Importing from Memory Card

Put the card into your card reader. Make sure the card reader is plugged in to the computer and
switched on.

The card reader and card should be detected automatically.

Follow the instructions for importing photos from your hard disk. If you click File ▸ Import From
Folder, the memory card should be visible as a folder in the side bar of the file selection window.

Shotwell  can import  photos from any memory card that  is  compatible with  your  card
reader.

If the card is not detected automatically, your card reader may not have been recognized.
Try unplugging it and then plugging it in again. If that doesn't work, you should still be able to
import photos by connecting your camera directly to the computer, though.

Edit

If  you double click or press enter on an image, you enter Edit  mode, where you can
remove red-eye, crop, and adjust brightness and colors.

Versions

When you edit your photos, a new copy (called a version) is created, so your original is
never altered. After your first edit a photo, subsequent edits will modify the same version. If you
want to create mulitple versions of your photo, perhaps with different cropping or coloring, you
can do so via the   Photo -> Create New Version... option.
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Crop

Cropping an image is a great way to improve the quality of a photograph by improving
how it is framed. You crop a photo by selecting the part of the photo you want to keep. If you
want your photo to be the exact dimensions necessary for a certain print size, you can constrain
the kind of selection. F-Spot will allow you to draw by choosing the appropriate size from the
constraint drop down.

Once you have made your crop selection, you must click the crop button beneath the
image to finalize the crop. If you are working with the original photo, cropping creates a new
version your photo.

Straighten

Straighten effect is a tool to level a photo. 

This tool  rotates an image by a  specified angle  and automatically  crops the resulted
image, so that you always see a perfect rectangle.

Adjust Colors

To adjust  the brightness,  contrast,  and colors  of  a  photo,  first  click  the “Adjust  the
photo colors” icon to open the “Adjust Color” dialog. Change then some settings and save
them with OK.

AutoColor

This effect automatically adjusts color levels to make a pretty balanced picture color-wise.
It serves best for pictures taken with automatical white balance, when camera didn't manage to
do the job well.

Desaturate

To make a colorful  photo a  black and white one,  open a photo of  choice and press
Desaturate button.

Sepia

To make a colorful photo look like an old-style picture in sepia tones, open a photo of
choice and press Sepia button.

Remove Red-Eye

To remove redeye from a photo, you need to select a zone containing the eyes. You may
want to zoom in on the image to accurately select the eyes in the photo. You should be able to
correct both eyes on the same person in one shot, or even the eyes from multiple people at once.
If this doesn't work for you, or the selected zone contains some vivid  red parts (lips, ...) you'll
probably have to correct one red eye at a time. 

To make your selection, click one corner of the rectangle that will be your selection, and
drag your mouse to the diagonal corner and release it. You can resize your selection by dragging
its edges, and you can move it by clicking in the middle of it and dragging it to where you want it.

Once you have selected a zone, you can remove the red from it by clicking the red-eye
button beneath the photo.
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Soft Focus

In photography sharpening one region of a picture, while blurring all the rest, is a way to
make an emphasis and grab attention. It is achieved by using a lens that allows shooting with a
short  distance in front of and beyond the subject that appears to be in focus. Soft focus effect is
a  way to emulate such a lens.

Click to choose central point of the area you want to be in focus and adjust amount of
blurring, then click OK.

Sharpen

Out-of-focus photographs and most digitized images often need a sharpness correction. The
Unsharp Mask effect sharpens edges of the elements without increasing noise or blemish. To
sharpen a photo choose Edit -> Sharpen... and specify the following values:

Amount — strength of sharpening.

Radius — how many pixels on either side of  an edge will  be affected by sharpening. High
resolution images allow higher radius.

Threshold — the minimum difference in pixel values that indicates an edge where sharpen must
be applied. This helps avoiding creation of blemishes in face, sky or water surface.

 Describe

You can also enter a description of the image by clicking on the text entry box below the image
and typing. 

Adjust Time

In both 'browse' or 'edit' modes, you can adjust the time of one or multiple pictures (Edit ->
Adjust Time). 

Tag

F-Spot enables you to organize and enjoy your photos by associating them with various user-
customizable tags. A tag is a merely a label. F-Spot comes with default tags to get you started.
You are free to change them and add new ones. For example, if you want to create a tag for
specific event, you can create a new tag named after that event under the Events tag.

There are many ways to tag photos:

drag and drop the photo(s) onto the tag

drag and drop the tag onto the photo(s)

via the photo's right-click menu

via the Tags and Edit menus

by typing them in (press t to pop up the tag entry bar, enter comma-separated tags) - with tab
completion!

The first photo you associate with a tag will be used for that tag's icon. You can always edit a
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tag's name, parent tag, and icon by right clicking on it and choosing Edit tag.

You can change a tag's parent by dragging and dropping it where you like. Also, you can edit the
name of a tag by selecting it and pressing F2. Lastly, if you have the tag tree widget focused
(e.g. you just clicked on a tag), you can start typing the name of a tag, and all the expanded tags
in the list will be searched and you'll jump to any matching ones. 

You can also  change size  of  tag icons  in  the sidebar  or  even make tag icons  invisible  by
selecting preferred option from View -> Tag Icons menu.

 11.2.2 Enjoying your photos

Browse

You can use the slider widget to browse your photos by month or by directory. To change this
setting, go to View -> Arranged By.

Fullscreen Mode and Slideshows

For fewer distractions and larger display, you can view your photos in full screen mode. You
control  when to show the next  photo or  to return to the previous.  Enter  fullscreen mode by
pressing F11 at any time or by pressing the button in the toolbar. 

In slideshow mode, you can sit back and view your photos as they are presented to you. You
can start a slideshow by pressing the button on the toolbar. 

 11.2.3 Sharing your photos

There are many ways to share your photos using F-Spot. All of the following methods will only
share the photos you have selected when you run them.

E-mail

E-mail your photos directly from F-Spot with the Photo -> Send by Mail... menu.

Print

Print your photos with the Photo -> Print menu.

Burn to CD

Burn your photos to CD or DVD with the Photo -> Export to -> CD... menu.

Post photos to your online galleries

If you use Flickr, SmugMug, 23hq or Picasa Web Album, you can post your files directly from  F-
Spot with the Photo -> Export to menu, choosing corresponding submenu item.

 11.3 Scanner Usage
Plug-in  the  Scanner  and  select   XSane  Image  Scanning  Program  from  Applications  ->
Graphics -> Simple Scan or type  simple-scan  in terminal and press Enter 
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The scanner will be detected and the images can be scanned now.
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 12 Special Purpose Tools

 12.1 Migration Tool
BOSS Bulk Document Converter 

This converter allows you to convert one format of documents into the other format of documents
like doc to pdf, doc to html etc.,

Usage:

 Place all the documents that need to be converted into one source folder and create an
empty folder as destination folder.

 Choose Applications -> Office->BOSS Bulk Document Converter or type converter
in terminal and press Enter.

 Select the source and destination folders and the respective formats to be converted.

 You will find your converted documents in the destination folder.

Source and Destination selection

Once we select the Bulk Document Converter,  this window will  open, where we browse the
source and destination folder or copy and paste the pathname of the folders. Then click “Next”
to proceed.

           Figure 1. Source and Destination selection screen
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Overall Document type

After   the  source  and  destination  selection,  there  comes  a  first  level  of  categorization  of
documents. According to the format of the source file, we have to select the document type.

Figure 2. Overall Document type

Exact source format

Next, the sub-categories of the general overall document type, that we selected  appears. Select
the exact format of the source. Click “Next” and then proceed.

Figure 3. Source Document type 
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Destination type

The possible destination type format for the selected source format appears now. Select the
appropriate format from the list. Once selected, click “Next” to proceed.

Figure 4. Destination Document type

Conversion

Finally, the warning page for the conversion appears, if you click “Next”, the conversion gets
completed.

The screen shots are as follows:

          Figure 5. Warning screen
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  Figure 6. Conversion Completed

 12.2 BOSS Presentation Tool
BOSS Presentation tool is the KeyJnote application. KeyJnote is a simple presentation program
that displays slide shows of image files (JPEG, PNG, TIFF and BMP) or PDF documents. 

To open BOSS Presentation Tool choose,  Applications->Office->BOSS-Presentation-Tool
or type boss-presentation-tool in terminal and press Enter.
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To display images using the presentation tool click “Directory with Images” option. Click the 
“Browse” button and select a directory(folder) containing one or more  images. 

To  display  a  PDF  or  PPT  or  PPS  or  ODP  file  using  the  presentation  tool  click
“PDF/PPT/PPS/ODP  File”  option.  Click  the  “Browse”  button  and  select  the  file  with
extension .pdf or .ppt or .pps or .odp 

Transitions

Any number of transitions can be applied. The "Available Transitions" box contain a list of all the 
available transitions. To apply a transition click the transition and click the "Forward" button. The
selected transitions will be moved to the "Selected Transitions" box. 
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To remove any of the selected transition click the corresponding transition and click "Back" 
button.

Cursor Image

Instead of using the normal mouse pointer, an image can be used as Cursor.
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Run Time of the presentation

While giving presentation some time limits will be there. The presenter will not be aware of how 
much time is left out while giving the presentation. For this the user can specify the time limit. 

A progress bar will appear at the bottom of the slide showing the remaining time. If some time is 
left out the bar will be in "green" color. If the time is over the color of the bar will change to "red". 

Wrap
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After the last page of the presentation if the first page should appear again set the wrap option 
as "Yes".

Initial Page

By default the presentation will start from the first page. To start the presentation from a page 
other than the first page use the "Initial Page" option.  

Executing the presentation
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To execute, choose Presentation -> Execute from the menu or Press "Execute" icon from 
toolbar. Keyboard Shortcut – F8.

Keyboard and Mouse Operations

Q key or Esc key 

    Quit BOSS Presentation Tool immediately.

LMB (Left Mouse Button), Page Down key, Cursor Down key, Cursor Right key or 
Spacebar 

    Go to the next page. 

RMB (Right Mouse Button), Page Up key, Cursor Up key, Cursor Left key or 
Backspace key 

    Go to the previous page.

Home Key / End Key 

    Go directly to the first or last page of the presentation.

F key 

    Toggle fullscreen mode.

Tab key or MMB (Middle Mouse Button) 

    Zoom back to the overview page. While in overview mode, a page can be selected with the 
mouse and activated with the left mouse button. The right or middle mouse button or the Tab 
key leave overview mode without changing the current page.
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LMB over a PDF hyperlink

    Jump to the page referenced by the hyperlink.  Only hyperlinks that point  into the same
document are supported; inter-document links or web links will be ignored. This feature is only
available if pdftk is installed. Furthermore, it will not work properly when pages are rotated.

Click & Drag with LMB (Left Mouse Button) 

    Create a new highlight box. While at least one highlight box is defined on the current page, the
page  itself  will  be  shown in  a  darker  and blurry  rendition.  Only  the  highlight  boxes  will  be
displayed in their original lightness and sharpness. If  a page with highlight boxes is left, the
boxes will be saved and restored the next time this page is shown again.

RMB (Right Mouse Button) over a highlight box 

    If the right mouse button is clicked while the mouse cursor is above a highlight box, the box
will be removed. If the last box on a page is removed, the page will turn bright and sharp again.

  

S key 

    Save the info script associated with the current presentation. The main purpose for this is to 
permanently save highlight boxes so they will be restored the next time this presentation is 
started.

T key 

    Activate or deactivate the time display at the upper-right corner of the screen. If the timer is 
activated while the very first page of the presentation is shown, it activates     »time tracking» 
mode. In this mode, a report of all pages visited with their display    duration, enter and leave 
times will be written to standard output. This will be very     useful when preparing presentations.

R key 

    Reset the presentation timer.

Return key or Enter key 

    Toggle spotlight mode. In this mode, the page is darkened in the same way as if highlight 
boxes are present, but instead of the boxes, a circular “spotlight” will be shown around the 
mouse cursor position, following every motion of the mouse cursor.

+ key / – key or mouse wheel 

    Adjust the spotlight radius.

Z key 

    Toggle zoom mode. When this key is first pressed, the current page will zoom in. In zoom 
mode, all other functions will work as normal. Any operations that leave the current page, such 
as moving to the next or previous page or entering the overview screen, will leave zoom mode, 
too.

O key 
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    This will toggle the »visible on overview page« flag of the current page. The result will not be 
visible immediately, but it can be saved to the info script (using the S key) and will be in effect 
the next time the presentation is started.

I key 

    This will toggle the skip flag of the current page. A page marked as skipped will not be 
reachable with the normal forward/backward navigation keys.        

Click & Drag with RMB (Right Mouse Button) in zoom mode 

    Moves the visible part of the page in zoom mode.

Cursor keys in overview mode 

    Navigate through pages.        

Any other alphanumeric (A-z, 0-9) or function key (F1-F12) can be used to assign shortcuts to 
pages that require quick access. If one of the keys is pressed together with Shift, the currently 
displayed page is associated with this key. To recall the page later, it is sufficient to press the 
shortcut key again. Shortcuts can be permanently stored with the S key.   

 13 Playing Music and Movies

 13.1 Banshee Music Player
Banshee is a music management and playback application for GNOME.

Banshee has a beautiful user interface and is well architecture.

Features:
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 Import CDs 
 Manage your library 
 Play your music 
 Create and maintain playlists 
 Sync music with your iPod 
 Play music directly from your iPod 
 Create audio and mp3 CDs 

To start Banshee Music Player, choose Applications -> Sounds & Video -> Banshee Media
Player or type banshee in terminal and press Enter.

 13.1.1 Importing Music 
 To import music, click "Music", then "Import Media..." and choose the location on your hard
drive to import your music. You can import digital music files including OGG, FLAC, MP3 or
WAV.  Banshee will then sort your music based on artist, track name, track number or album.
Clicking on one of the columns will make Banshee sort in that order. 

To import music from an audio CD, insert the CD in your CD-ROM drive.  The left hand side of
Banshee on the side menu will display a CD icon.

Click on the CD icon on the left bar to display the songs on the CD.  Click on "Import CD" in the
upper right hand corner and Banshee will import the songs into your collection in the file format
you've chosen in your Preferences.  To choose the file format (OGG, MP3, FLAC or WAV), click
Edit -> Preferences. In the “CD Importing” section choose the format from the “Output Format”
drop down menu. 

 13.1.2 Podcasts 
Banshee supports subscribing and listening to Podcasts.  Choose "Podcasts" on the left hand
side menu.  To subscribe to a Podcast, click on "Subscribe to Podcast".  Enter the URL of the
Podcast you would like to subscribe to. Banshee will then begin to download the latest Podcast,
and show all available downloads for the URL in the bottom pane.  Click on the check box to
download additional Podcasts. 

 13.1.3 Playing Audio CDs
To play your CD, insert it into your drive. It should automatically appear within Banshee in your
sources list,  beneath your Music Library and Video Library  sources.  You can click the new
source (named Audio CD, or the name of the album) and double click a track in it  to begin
playback.
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 13.1.4 Importing/Ripping Audio CDs
1. Insert a CD 
2. Banshee automatically detects it and adds it to the side menu; click it 
3. Uncheck any tracks you don't want imported 
4. Press the Import CD button, located near the upper-right corner of Banshee 
5. Banshee will begin importing the CD. As it finishes each track, it will appear in your Music

Library 

Adjusting Your Preferences

You  can  change  your  CD  importing  preferences.  Go  to  the  Edit menu,  and  choose  the
Preferences menu item. Within the Preferences dialog, choose the Audio CD tab.

Import format

The defaults should be fine, but if you prefer to have your music imported as a certain file
type (.mp3, .wma, or something else) or with certain quality settings (128kbps, 256kbps,
etc) you can set that here. If you don't see the file format you want, you need to ensure
you have the appropriate GStreamer plugin/codec installed.

Automatic import

With this item checked, Banshee will automatically begin importing as soon as you insert
an audio CD - unless it can't find the track list (album name, track titles) for it, or it detects
you already have at least part of the album imported.

Eject when done importing

If you want Banshee to automatically eject your audio CDs after importing them, check
this.

 13.2 Movie Player
Totem is the official movie player of the GNOME desktop environment. It is also BOSS's default
video player. Totem plays any xine or gstreamer-supported file. It enables you to play movies or
songs. 

To start Totem, choose Applications -> Sounds & Video -> videos or type totem in terminal
and press Enter.

Totem Movie Player provides the following features:

Support a variety of video and audio files.

Provide a variety of zoom levels and aspect ratios, and a full screen view.
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Seek and Volume controls.

A playlist.

A complete keyboard navigation.

Totem Movie Player also comes with additional functionalities such as:

Video thumbnailer for GNOME.

Nautilus properties tab.

 13.2.1 Opening a File
To open a video or an audio file, choose Movie -> Open (Ctrl+O). “Select Movies or Playlists”
dialog is displayed. Select the file you want to open, and click “OK”. 

You can drag a file from another application such as a file manager to the Totem Movie Player
window. The Totem Movie Player  application will  open the file and play the movie or  song.
Totem Movie Player displays the title of the movie or song beneath the display area and in the
title bar of the window.

If  suitable codecs for the format your are trying to play is not installed the following window
appears:
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Once “Search” is clicked a window appears showing the list of available codecs. Select the
codecs you want to install and click “Install”.

Once the installation of codecs is completed you can play the song or movie.

 13.2.2 Opening a Location
To open a file by URI location, choose Movie -> Open Location (Ctrl+L). The Open from URI
dialog is displayed. Use the drop-down combination box to specify the URI location of file you
would like to open, then click on the Open button.

 13.2.3 Play a Movie (DVD or CD)
Insert the disc in the optical device of your computer, then choose Movie -> Play Disc.

 13.2.4 Eject a DVD or CD
To eject a DVD or CD, choose Movie -> Eject (Ctrl+E).

 13.2.5 Pause a Movie or Song
To pause a movie or song that is playing, click on the Pause button at the bottom left of the
window, or choose  Movie -> Play/Pause. When you pause a movie or song, the status bar
displays “Paused” and the time elapsed on the current movie or song stops.

To resume playing a movie or song, click on the Play button, or choose Movie -> Play/Pause.

 13.2.6 View Properties of a Movie or Song
To view properties of a movie or song, choose View -> Sidebar to make the sidebar  appear,
and choose “Properties” in the drop-down list.

The dialog contains the following information:

General - Title, artist, year and duration of movie or song.

Video - Video dimensions, codec and frame rate.

Audio - Audio bit rate and codec.

Changing the Video Size
To change the zoom factor of display area, you can use the following methods:

To zoom to full screen mode, choose View -> Fullscreen or press F11
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To exit fullscreen mode, click on the “Leave Fullscreen” button or press Esc or F.

To zoom to half size (50%) of the original movie or visualization, choose View -> Fit Window
to Movie -> Resize 1:2 .

To zoom to size (100%) of the original movie or visualization, choose View -> Fit Window to
Movie -> Resize 1:1.

To zoom to double size (200%) of the original movie or visualization,                   choose View ->
Fit Window to Movie -> Resize 2:1 .

 13.2.7 Adjusting the Volume
To increase the volume, choose Sound -> Volume Up (Up Arrow) or move the volume slider
to the right.

To decrease the volume, choose Sound -> Volume Down (Down Arrow) or move the volume
slider to the left.    

To adjust the sound volume, you can also use the volume button in the panel or keyboard. Press
the volume button and choose the volume level with the slider.     

 13.2.8 Make Window Always On Top
To  make  the  Totem  Movie  Player  window  always  on  top  of  other  application  windows,
choose View -> Always on Top    

 13.2.9 Repeat Mode
To enable or disable repeat mode, choose Edit -> Repeat Mode.  

 13.2.10 Shuffle Mode
To enable or disable shuffle mode, choose Edit -> Shuffle Mode

 13.2.11 PlayList
To show playlist, choose View -> Sidebar, or click the Sidebar button, and choose “Playlist”
on the top of the sidebar. The Playlist dialog is displayed.

To hide Playlist, choose View -> Sidebar or click on the Sidebar button again.

You can use the Playlist dialog to do the following:

Adding a track or movie - To add a track or movie to the playlist, click on the “Add...” button.
The Select files dialog is displayed. Select the file that you want to add to playlist, then click
“OK”.

Removing a track or movie - To remove track or movie from the playlist, select the filenames
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from the filename list box, then click on the “Remove” button.

Saving playlist to file - To save playlist to file, click on the “Save” button. The Save playlist
dialog is displayed, specify the filename that you want to save the playlist.

Moving track or movie up the playlist  -  To move track or movie up the playlist, select the
filenames from the filename list box, then click on the “Up” button.

Moving track or movie down the playlist - To move track or movie down the playlist, select the
filenames from the filename list box, then click on the “Down” button.

 13.3 Restricted Formats 
BOSS GNU/Linux strives to make every piece of software available under the licensing terms
laid out in the BOSS GNU/Linux License Policy. Patent and copyright restrictions complicate the
ability of a free operating system to distribute software that will support proprietary or non-free
formats. 

BOSS GNU/Linux's commitment to only include completely free software by default means that
proprietary media formats are not configured 'out of the box'. This page will show you how to
enable support for the most popular non-free media formats. 

These are non-Free formats and tools, well-known from the Win32 world. The most important
ones are Java, Windows Media, Real Media, Real Player, DVD-video, Macromedia Flash, AAC
and iTunes Music Store and some other Video and Audio Codecs. All of them are not included
within the BOSS standard installation. You have to install them manually. 

How to play restricted formats with BOSS GNU/Linux(media codecs) 

You can install the multimedia codecs with the following steps 

1) Update your sources.list with BOSS repo, so open the terminal and execute the following
command

  #vi /etc/apt/sources.list

2) Add the following line in that file

  deb http://packages.bosslinux.in/boss BOSS main contrib non-free

3) Save the file and quit, Esc+:+wq

4) Open the terminal and execute the following commands

 # sudo apt-get update  

 # sudo apt-get install gstreamer0.10-plugins-bad

 # sudo apt-get install libarts1-mpeglib

 # sudo apt-get install libarts1-xine
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 14 Burning CDs and DVDs
K3B is a CD and DVD burning application for Linux systems. It provides a comfortable user
interface to perform most CD/DVD burning tasks like creating an Audio CD from a set of audio
files or copying a CD. 

To start the application, select Applications -> Sound & Video -> k3b or type k3b in terminal
and press Enter.

 14.1 Creating a Data CD or DVD
To create a Data CD choose “Data CD” from the Compilation Browser. To create a Data DVD
choose “Data DVD” from the Compilation Browser. Then drag the files you want to burn on the
CD or DVD from the File system Browser to the Compilation Browser. 
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Then press “Burn” in the lower right corner. After clicking it, you will see the following dialog:

Use the “Writer” drop down menu to select your writer.

Select the speed that you want to burn the CD.

Select the “Eject disk” option so k3b would eject the disc after finishing the writing.
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 14.2 Creating an Audio CD

To create an Audio CD choose “Audio CD” from the Compilation Browser. Then drag the music
files you want to burn on the CD from the File system Browser to the Compilation Browser. 

Then press the “Burn” button in the lower right corner. After clicking it, you will see the following
dialog: 

Use the “Writer” drop down menu to select your writer.

Select the speed that you want to burn the CD.

Select the “Eject disk” option so k3b would eject the disc after finishing the writing.
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 14.3 Copying a Data CD or DVD
To copy, choose Tools -> Copy Data CD or Tools -> Copy DVD depending upon your media.
The application will show the following dialog:

Use the “Reader” drop down menu to select the reader from which the data will be copied.

Use the “Writer” drop down menu to select your writer.

Select the speed that you want to burn the CD.

Select the “Eject disk” option so k3b would eject the disc after finishing the writing.

 14.4 Blank a CD-RW
To erase a CD-RW, choose  Tools -> Format/Erase rewritable Disk.  The application will
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show the following dialog:

 Use the “Writer” drop down menu to select your writer.

 Select the speed that you want to burn the CD.

 Select the “Eject disk” option so k3b would eject the CD-RW disc after erasing it.

 Select the “Fast blank” option to activate this method of blanking.

 14.5 Burn an ISO Image
To burn an ISO image, choose  Tools -> Burn Image. Navigate through the directories and
after selecting the ISO file which you want to burn, press “OK”.

 15 Partition Editor
Partition Editor is the Gnome Partition Editor application. Partition Editor is an industrial-strength
package for creating, destroying, resizing, moving, checking and copying partitions, and the file
systems on them. This is useful for creating space for new operating systems, reorganizing disk
usage,  copying  data  residing  on  hard  disks  and  mirroring  one  partition  with  another  (disk
imaging).

To work with partition table, click,  System ->System Tools -> GParted or  type gparted in
terminal and press Enter.

If you click the “Gparted” menu(at the top left), a pop down menu is presented. You can select
“Refresh Devices” to refresh the display of  the drives on your  system. As well,  a keyboard
shortcut(Ctrl+R) can also be used to refresh the screen information. With the second choice, you
can choose the hard drive whose partitions you want to modify. This is useful if you have more
than one hard drive. The third option under “Gparted” menu is used to obtain more information.
It  opens a new window from which you can see the supported file-types and some partition
editing options.

The “Edit” menu shows two greyed out functions which are quite useful: Undo and  Apply. These
options may also be seen in the toolbar. To activate them, you must  choose a partition you wish
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to modify.

The “View” menu allows you to access/view other areas :

Device Information: The device information panel displays details about the hard disk, such as
Model, Size etc. This panel is most useful in a multi hard disk system, where the information is
used to confirm that the hard disk being examined is the one that is wanted.

Pending Operations: At the footing window is a list of pending operations. The information is
useful as it provides an indication of the number of pending operations.

“Device” menu allows you to set a Disk Label....

If the current disk label is inappropriate, you may change it using  Device -> Set Disklabel...
option.

The “Partition” menu is most import. It allows you to do many operations, we can create a new
partition, some of which are dangerous. Select “Delete” if  you want to delete a partition. To
perform the delete, you must first select the partition.

“Resize/Move” is a useful function. we can resize or move a partition using this option.

You may also format any partition to a file system which is supported in the menu.

The last choice gives information about the selected partition.

Note: Before doing any of the following operations, make sure that the partitions are unmounted.

Few operations:

Creating a new partition:

Select an unallocated area and click the “New” button in the toolbar to create a new partition. A
new window appears and lets you chose the size, file system, type of partition etc.5,

Deleting a partition:

The second icon on the toolbar is for deleting the selected partition. If  you want to delete a
partition, select that partition and click the “Delete” icon and then click “Apply”.

Resizing a partition:

At the top right-end of the screen there is a drop-down box where you can choose the hard disk
you want to work on, if you have several hard drives on the PC/machine. Remember that this will
only become operational after the scan is completed. 

Click the partition that is to be resized and then select “Resize/Move” from the “Partition” menu
or click “Resize/Move” icon from the toolbar.

Now you can increase or  decrease the size  of  the partition.  If  you have free space in that
partition, then only you can decrease the size of the partition. If you have free space in the hard
disk then only you can increase the size of the partition.
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Once you have done your job, click on “Apply”. No operations are given to the hard disk until
you click  “Apply”. 

Copying a partition: You must first select the partition you want to copy. Right-click on the 
partition and click “Copy”. After copying the partition, you must choose an   unallocated area to 
activate “Paste” button. You may wish to resize the partition you want to  paste: same size or 
bigger? (A smaller partition is impossible!). After you have pasted, you can click "Apply".

 16 Utilities

 16.1 Document Viewer
The Evince Document Viewer application enables you to view documents of various formats like
Portable Document Format (PDF) files and Post Script files.

To start  document viewer,  choose  Applications -> Utilities -> Document Viewer  or type
evince in terminal and press Enter.
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The Evince Document Viewer window contains the following elements:

Opening a document

To open a document choose File -> Open.... Choose the name of the file you want to open and
click “Open”. The name of the document will  be displayed in the title bar of the viewer. The
contents of the document will be displayed in the display area.

Navigating through the document

1.To view the next page do any one of the following:

Choose Go -> Next Page 

Click “Next” button in the toolbar.

2.To view the previous page do any one of the following:

Choose Go -> Previous Page

Click “Previous” button in the toolbar.

3.To view the first page in the document Choose Go -> First Page

4.To view the last page in the document Choose Go -> Last Page

5.To view a particular page, enter the page number in the “Select Page” text box on the toolbar,
then press Enter.
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Changing the page size

1. To increase the page size, choose View -> Zoom In. Short cut key is Ctrl++

2. To decrease the page size, choose View -> Zoom Out. Short cut key is Ctrl+-

3. To resize a page to have the same width as the Evince Document Viewer display  area,
choose View -> Fit Page Width.

4. To resize a page to fit within the Evince Document Viewer display area, choose  View ->
Best Fit.

5. To resize the Evince Document Viewer window to have the same width and   height as
the screen, choose View -> Full Screen. To resize the Evince Document Viewer window
to the original size, click on the “Leave Full Screen” button.

Viewing the Pages or Document Structure

To view any page, perform the following steps:

1. Choose View -> Side Pane or press F9.

2. Use the drop-down list in the side-pane header to select whether to display document
structure or pages in the side pane.

3. Use the side-pane scrollbars to display the required item or page in the side pane. Click
on an entry to navigate to that location in the document. Click on a page to navigate to
that page in the document.

Viewing the Properties of a Document

To view the properties of a document, choose File -> Properties. Short cut key is Alt+Enter.

The Properties dialog displays all information available.

Printing the document

To print the document, choose File -> Print

Copying the document

To copy a file, perform the following steps:

1. Choose File -> Save a Copy... 

2. Select the location where you want to save the file and give a new name for the copy.

3. Click “Save”.

Working With Password-Protected Documents

An author can use the following password levels to protect a document:

User password that allows others only to read the document.

Master password that allows others to perform additional actions, such as print the document.
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When you try to open a password-protected document, Evince Document Viewer displays a
security dialog. Type either the user password or the master password in the “Enter document
password” text box, then click “Open Document”.

Closing the document 

To close the document, choose File -> Close

 16.2 Image Viewer
gThumb is  an  image viewer  and browser  written for  the GNOME environment.   It  lets  you
browse your hard disk, showing you thumbnails of image files and view single images of many
different formats.

The most common image formats are JPEG and GIF. The JPEG format is good for medium and
big sized images because it has a high compression rate keeping a good image quality. The GIF
format is used in Web pages for displaying little animations or little static images.

Another important image format is PNG, this format is very common on Unix platforms and is
considered a replacement of the GIF format.

gThumb supports all this formats and many others, it also displays GIF animations.

gThumb not only lets you view image files but has many other features such as add comments to
images,  organize  images  in  catalogs,  print  images,  view  slide  shows,  set  your  desktop
background, and more.

To start Image Viewer choose Applications -> Graphics -> gThumb Image Viewer or type
gthumb in terminal and press Enter.
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 16.2.1 Sort Images

To sort  images in a different order choose  View -> Sort Images,  use  Ctrl+R to reload the
current folder,  type T to view or hide the thumbnails in the images list.

 16.2.2 To Add a Folder to the Bookmarks

Frequently used folders can be added to the bookmark list for rapid access.  Just go to the folder
you want to add to the bookmarks and press Ctrl+D or use the menu item        Bookmarks ->
Add Bookmark.

To  remove  or  rearrange  bookmarks  in  a  different  order  choose  Bookmarks  ->  Edit
Bookmarks...

 16.2.3 Viewing Images

In order to view an image just  click on its thumbnail  and the image will  be visualized in the
viewer pane.  If the image doesn't fit the viewer pane you can give more space to the viewer
hiding the browser, this can be accomplished by double-clicking on the thumbnails or pressing
the Return key, pressing it again the browser will be displayed again.

Another  way  of  viewing  a  big  image  is  to  view  it  in  full  screen  mode.  Type  F to
activate/deactivate the full screen mode.

Mouse operations :

Holding down the left button and moving the mouse move the image

Left-click Show next image

Middle-click Show previous image

Right-click Pop up the image menu

Another way of moving images is by the navigation button located in the right bottom corner of 
the viewer window when the images does not fit in the window. Clicking and holding this button 
will show you a preview of the image.  Moving the mouse you will move the image to the desired 
position.

 16.2.4 Viewing the Image Properties

 To view the image properties, perform the following steps:

1. Select the image.

2. Choose File -> Properties. gThumb displays a Properties dialog.

 16.2.5 To View the Image EXIF Data

To view the exif data attached to an image, use the Properties dialog or perform the following 
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steps:

1. Select the image.

2. View the image pressing Return or double clicking on it.

3. Press I. gThumb displays the exif data.

 16.2.6 Comments

Comments are pieces of information attached to images.

Adding Comments

To add a comment to an image select the image and choose Edit -> Comment... or type C.

Comments are structured in various parts :

Comment: a free text describing the picture.

Place: the place the picture represents.

Date: the date the picture was taken.

Image comments are displayed in the image list in italic text above the image filename.  If the 
comment is too long the symbol "[..]" is appended to the displayed part of the comment to signal 
you that the comment is not entirely visible. To view the whole comment use the image 
properties dialog that can be displayed using the File -> Properties menu item or pressing I.

Add Comments to Many Images

To add a comment to many images, select the images and choose Edit -> Comment... or type 
C.

The Comment dialog will fill in the fields that have the same value for all the images leaving all 
other fields empty.

You can activate the “Save only changed fields” option to change one or more fields of many 
comments leaving all other fields unchanged.

Removing Comments

To remove comments, perform the following steps:

1. Go to the folder or catalog where the images are.

2. Select  the  images  and  choose  Edit  ->  Remove  Comment.  gThumb  removes  the
comments.

To View an Image Comment

To view an image comment, use the Properties dialog or perform the following steps:

1. Select the image.

2. View the image pressing Return or double clicking on it.
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3. Press I. gThumb displays the image comment.

 16.2.7 Catalogs

Catalogs lets you organize images without moving them from a folder to another, think of them
as playlists for images.

Catalogs can be organized in libraries. A library is like a folder that can contain catalogs and
other libraries.

To Create a Catalog

 To create a catalog, perform the following steps:

1. Set the catalogs view by selecting View -> Catalogs or pressing Alt+2. 

2. Choose File -> New Catalog...

3. Enter the catalog name and click on “OK”.  gThumb creates the catalog.

To Add Images to a Catalog

To add a series of images to a catalog, perform the following steps:

1. Select the images you want to add to the catalog and choose Edit -> Add to Catalog. A
window titled “Choose a Catalog” appears.

2. Select an existing catalog or create a new one by clicking “New Catalog” button.

3. Choose “OK”.  gThumb adds the selected images to the catalog.

To View the List of Catalogs

To view the list of catalogs, perform the following step:

1. Press Alt+2 or choose View -> Catalogs.

To View a Catalog
To view the content of a catalog, perform the following steps:

1. Set the catalogs view by selecting View -> Catalogs or pressing Alt+2. 

2. Select the catalog by clicking on the catalog name.

3. If you want to go to the image folder, select the image and use the  Go -> Go to the
Image Folder. gThumb will display the image folder and will scroll the image list in order
to make the image visible.

To Remove Images from a Catalog

To remove images from a catalog, perform the following steps:

1. Set the catalogs view by selecting View -> Catalogs or pressing Alt+2. 

2. Select the catalog.

3. Select  the  images  you  want  to  delete  and  choose  Edit  ->  Remove from Catalog.
gThumb removes the images from the catalog.
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To Rename, Remove or Move a Catalog

To rename, remove or move a catalog, perform the following steps:

1. Set the catalogs view by selecting View -> Catalogs or pressing Alt+2. 

2. Select the catalog.

3. Choose File -> Catalog or use the context menu that can be displayed pressing the right
mouse button on the name of the catalog in the catalog list.  

 16.2.8 Slide Show

You can start a slide show of the images in the current folder by pressing F12 or selecting the 
View -> Slide Show menu item.

To stop the slide show press S or Esc.

Switching on/off the full screen mode does not stop the slide show.  If the Switch to full screen 
option is on then the slide show is started in fullscreen mode and exiting from the fullscreen 
mode will stop the slide show.

The slide show is interrupted when you change folder or re-load the current one.

With the slide show tool and the fullscreen mode you can do presentations. There are two types 
of presentations: automatic presentations and manual presentations.

Automatic Presentation

To do an automatic presentation, perform the following steps:

1. Go to the folder or catalog containing the images you want to present.

2. Select the images you want to view in the slide show, or select none to view all the 
images in the current folder or catalog.

3. Press F12 or choose View -> Slide Show. gThumb starts an automatic presentation of 
the images. To stop the presentation press S or Q or Esc.

Manual Presentation

To do a manual presentation, perform the following steps:

1. Go to the folder or catalog containing the images you want to present.

2. Select the image from which you want to start the presentation.

3. Press F. gThumb displays the image in fullscreen mode.

4. Press Space or N. gThumb displays the next image.

5. Press BackSpace or B. gThumb displays the previous image.
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To stop the presentation press Q or Esc.

 17 Changing the name of Applications
in BOSS

If you like to change the name of the applications, BOSS gives you an option to change those
names.

Press the Windows Key then type in the search box “Main Menu” then Enter 

or Click  Applications → System Tools → Main Menu then type in the search box “Main
Menu” then Enter 

or  Click Applications → Activities Overview then type in the search box “Main Menu” then
Enter 

A  window appears as shown in the figure.

 17.1 Changing the name of main menu
Follow these steps to change the name of main menu:

1. Double-click the application name to change the name of  that  application.  For  eg:  to
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change the name of  Sound & Video to any other name(eg:Multimedia) in Items double-
click on “Sound & Video”. A window appears as shown in the figure.

2. Change the name “Sound & Video” to “Multimedia”.

3. Click “Close”. Also in the window titled “Main Menu” click  the “Close” button.

4. Click Applications. You can see that the name “Sounds & Video” has been changed to
“Multimedia”.
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 17.2 Changing the name of sub menu
Follow these steps to change the name of sub menu:

1. For eg: to change the name of  LibreOffice Impress to another  name(eg:Presentation)
click “Office” in Menus.

2. From Items double-click  “  LibreOffice Impress”.  A  window titled  “Launch  Properties”
appears. 

Change the name “ LibreOffice Impress” to “Presentation”. 
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3. Click “Close”. Also in the window titled “Main Menu” click  the “Close” button.

4. Click  Applications -> Office.  The name “ LibreOffice Impress” has been changed to
“Presentation”.
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 18 How to install ANYTHING in BOSS  !!
Thinking about how to install anything in BOSS GNU/Linux. .EXE files not working? Thinking
how to run the .EXE? Don't worry, installing softwares, packages, themes, skins and other things
are pretty easy in BOSS GNU/Linux. BOSS GNU/Linux provides you the  Synaptic Manager
which allows you to install  anything in easy steps with good and easy understandable GUI.
Initially have a look at the screen shots in this document, which will direct you in using synaptic
in your system.

 18.1 Synaptic Package Manager
Synaptic is a graphical package management program for apt. It provides the same features as
the apt-get command line utility with a GUI front-end based on GTK+. 

Features

 Install, remove, upgrade and downgrade single and multiple packages. 
 Upgrade your whole system. 
 Manage package repositories (sources.list). 
 Find packages by name, description and several other attributes. 
 Select packages by status, section, name or a custom filter. 
 Sort packages by name, status, size or version. 
 Browse all available online documentation related to a package. 
 Download the latest changelog of a package. 
 Lock packages to the current version. 
 Force the installation of a specific package version. 
 Undo/Redo of selections. 
 Built-in terminal emulator for the package manager. 
 Configure packages through the debconf system. 

The  synaptic,  refers  to  the  /etc/apt/sources.list  file  for  the  repository  links  and  installs  the
softwares from those repositories. So, before installing anything check whether you have the
correct entry in the sources.list file or not (by default these entries are present in the file). The
BOSS repository links are:

    deb http://packages.bosslinux.in/boss BOSS main contrib non-free

  deb-src http://packages.bosslinux.in/boss BOSS main contrib non-free  [to download source]

You can edit  this sources.list  file manually  and then open synaptic else,  after  you open the
synaptic, you can enter the above paths through Settings →  Repositories. 

To launch synaptic Package manager, go to Applications →System  Tools →  Synaptic
Package Manager or type synaptic in terminal and press Enter.
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It opens the Synaptic Window:

By this time you might have already decided which package or software to install. 

 Press  Ctrl+f  which opens the find window, where you can type the package name that
you want to install.   

 Or

 Click on any of the package in the window and start typing the package name, which will
let you see the packages with that name online (while typing). This opens the find window
in the bottom right corner.

After you find your package in the synaptic, right click on the package name, and select “Mark
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for  Installation”.  This  will  mark  the  package for  installation,  in  green color.  If  there  are  any
dependencies to install, it will show the dependent packages list in another window and their
status like, whether it is safe to install or not, whether the dependent package removes any other
package or  installs  any  other  packages,  whether  all  the  dependencies  are  available  in  the
repository or not, etc. So, proceed further by checking the dependencies properly. 

After you mark the package for installation, click on the “Apply” button in the top of the synaptic
window.  This starts the installation procedure.

Now  your  package  is  installed  successfully.  To  uninstall  any  installed  package,  the  same
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procedure but instead of selecting the “Mark for Installation” select “Mark for Removal”.  This
will open a new window which will show you the list of packages (dependent) to be removed.
Make sure that its not removing any base packages or needed packages.

Note: If your are having a DHCP connection then no need to bother. But if you are using the static IP, 
then you need to enter the details about your proxy server in Settings -> Preferences -> Network. 

 18.2 Where is my Binary File ?
BOSS GNU/Linux  uses  Debian Package Management  system.  You  might  have  been clear
about this now. So for any new application you need to search for the debian binaries are .deb
packages. You can initially check in the BOSS repository for the package. 

1) Use Synaptic Package Manager to install the package in the above mentioned method.

2) Manually install from the command prompt if you know the exact package name.

3) So, if the package is in the boss-repository, then download the package manually into
your  system and  use   dpkg -i  <package.deb>.  This  works  fine  only  if  there  are  no
dependencies to that file. If you find any dependencies then you have to download all the
files and install manually.

[ Better option is to use Synaptic Package Manager to install any software or package]

Install packages from Terminal 

 Open the terminal Applications -> Accessories -> Terminal. Execute 

       #  vi /etc/apt/sources.list

 Add the following if they are not added previously

http://packages.bosslinux.in/boss   BOSS   main contrib non-free 

           Save the file by typing  Esc+:+wq

 Now in terminal type the following commands

#apt-get update 

           #apt-get install <package name>

 If you are not finding the package in the repository then inform us at bosslinux@cdac.in.

 19 About BOSS Live
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The BOSS GNU/Linux Live project aims to create BOSS GNU/Linux Live CDs, DVDs, and
USBs for the all the releases of BOSS GNU/Linux (and newer). 

BOSS GNU/Linux Live is based on Debian GNU/Linux 

This chapter is about BOSS GNU/Linux, a Free and Open Source Live Linux DVD. BOSS is a
GNU/Linux  distribution  that  boots  and  runs  completely  from  DVD.  It  includes  recent  Linux
software and desktop environments, with programs such as LibreOffice, Abiword, Gimp, Mozilla,
Pidgin, XChat ,Totem, and hundreds of other quality open source programs. It  also includes
document converter, Presentation tool, bluetooth devices support and Input method for so many
Indian Languages. 

How to use BOSS GNU/Linux Live DVD   

 Boot with BOSS GNU/Linux DVD and select Start BOSS Live and press Enter. 
 BOSS GNU/Linux Live DVD boots and login with default user "boss". 
 In order to access admin privileges use "sudo" before every command. 

      For example:: sudo mkdir temp

 Users and Passwords: 

       users  Passwords
       -----  ---------
        boss    boss
        root    root

 Use external storage device(Pen/USB devices) or mounted hard disk partitions for saving
data.

 Remaining configurations and usage will be same as BOSS GNU/Linux Install section. 

 20 Troubleshooting BOSS GNU/Linux
If  you face any kind of problems with BOSS GNU/Linux, please inform us so that we will help 
you in solving it. But there are some basic issues that the lay users can also troubleshoot their 
systems on their own. This section gives you brief introduction of some of the problems and the 
steps to solve those issues. 
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 20.1 Forgotten User Password
Passwords are stored in encrypted files on your BOSS GNU/Linux system: users cannot read
the file and see their own or other passwords. If you forget your user password, you must create
a new one. 

If you realize that you have forgotten your password while logged in, you can create a new one
for yourself. Open a shell prompt and enter the command passwd. The passwd command asks
for the new password, which you will have to enter twice. The next time you log in, use the new
password. 

If you are not logged in when you realize you have forgotten your password, log in as the root
user. Open a shell prompt and enter the command  $passwd <username> where <username> is
your normal user name. The passwd command requires you to enter the new password twice.
Log out of your system. You can now log back in with your normal user name and your new
password. 

 20.2 Error Messages during installation of deb 
packages
While installing a deb package for any new application, you need to update the repository paths
appropriately in the /etc/apt/sources.list  file as explained in the previous chapter.  When you
execute the $apt-get update command at your shell prompt, if you see that the repositories are
not  connected,  then there may be a problem of  proxy settings.  If  you  are  using the DHCP
connection then it may not create problem unless you are able to access internet well. But if you
are using the internet through proxy server then you need to export the http_proxy parameter to
your proxy server ip and port number. If you don't have any idea about your proxy server then
contact your network administrator.

Example : $export http_proxy=http://192.168.31.100:3128 

Now you will see that an update on your repositories will work well.

Installing certain packages:

For installing a particular package, you need to know the exact package name of the application.
Use apt-get install <package name> to install a package if you know the exact package name. If
you are not sure with the full name of the package then you can search the related packages in
the repository by using the command apt-cache search <package name> where the <package
name> is your assumed package name, and this name can also have the meta characters
included for easy search, like php* gives all the versions of php like php-imap,php4-imap,php5-
imap etc. Once you find the exact package name, install it using the command  apt-get install
<package name>.  
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 21 Conclusion
The BOSS GNU/Linux project has given rise to an Indian distribution of GNU/Linux targeted at
the  primary and secondary school students.  Inspite of  the constraints on human resources, the
team was able to build this Linux distribution in a relatively short time. 

The project is ongoing and the next release of the software is currently being worked on. Further
the repository for BOSS GNU/Linux will make it easier to build customized distros based on it as
well as by application developers.

Choice of FOSS

Majority of government computer users require software for doing a number of common tasks
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like office applications (Word processor, spread sheet), accessing the Internet and multimedia in
a secured environment. However, to bring it on every desk the software should be low cost and
preferably  no  licensing  fees  at  all.  FOSS  and  GNU/Linux  in  particular  meet  all  these
requirements as it is free for use and can be freely copied, modified and distributed. It can also
be easily localized to meet local needs and language. GNU/Linux is also relatively immune to
common computer viruses, worms and spy ware. 

 21.1 About CDAC
Established  in  March 1988,  as  a  Scientific  Society  of  the  Ministry  of  Communications  and
Information Technology, Government of India, C-DAC is primarily an R&D institution involved in
the design, development and deployment of electronics and advanced Information Technology
(IT) products and solutions.

C-DAC has established itself  as premier R&D institution of  National  and International  repute
working  in  advanced  areas  of  Electronics  and  Information  Technology,  developing  and
deploying IT products and solutions for diverse sectors of the economy.

 21.2 About NRCFOSS
NRCFOSS  has  been  promoted  by  the  Department  of  Electronics  and  Information
Technology(DIETY), MCIT, Government of India to address the issues related to FOSS in the
Indian context and to explore how FOSS can play the twin roles of helping to bridge the digital
divide as well as strengthening the Indian software industry. 

One of the main objective of NRCFOSS is to come up with a local Indian GNU/Linux distribution
viz. BOSS ( Bharat Operating Systems Solutions). It was decided by a committee of experts to
have an Indian distribution of Linux so that the language used for the desktop environment and
some of the applications can be in the Indian language which will enable non-English literate
users in the country to be exposed to ICT and to use the computer more effectively. In the long
term, the BOSS GNU/Linux project will attempt to be the standard GNU/Linux distribution for
desktop computers in India.

 21.3 Contact Us
To know more about us, you can visit the NRCFOSS portal at http://nrcfoss.org.in/ and further
information  about  BOSS  GNU/Linux  and  recent  updates  can  be  found  at
http://www.bosslinux.in  .   Also you can talk to the BOSS Team Members online through the IRC
channel #BOSS-nrcfoss at Freenode.

Centre for Development of Advanced Computing(C-DAC),

8th Floor, D South & North,

Tidel Park Ltd.,

No.4, Rajiv Gandhi Salai,
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Taramani,

Chennai-600113

Ph: 91-44 - 2254 2226/27

Website: http://www.bosslinux.in

Email : bosslinux@cdac.in 

 21.4 BOSS Support Centres
Addresses of BOSS Support Centres in India

BOSS Support Centre

Centre for Development of Advanced Computing ,

Plot E-2/1, Block GP, Sector V,

Bindhanagar, Salt Lake,

Kolkata 700 091

Ph: 033 23573950

BOSS Support Centre

Centre for Development of Advanced Computing,

68,Electronics City,

Bangalore 560100

PH: 080 28523300

Email : bosslinux@ncb.ernet.in, bosslinux@cdacbangalore.in

----------------------------------------------------------------------------------------------------------------------------
------

BOSS Support Centre

Centre for Development of Advanced Computing ,

A-34, Phase 8, Industrial Area,

Mohali, Chandigarh 160 071

Punjab

Ph: 0172 2237054

----------------------------------------------------------------------------------------------------------------------------
------

BOSS Lab,C-DAC
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6 CGO Complex

Electronics Niketan

Lodhi Road

New Delhi -110003

Ph: 011 - 24301313

Email: bosshelp@mit.gov.in

----------------------------------------------------------------------------------------------------------------------------
------

BOSS Support Centre

Centre for Development of Advanced Computing,

Anusandhan Bhawan, C-56/1,

Sector 62,

Noida 201 307

Uttar Pradesh

PH: 0120 – 3063344

----------------------------------------------------------------------------------------------------------------------------
------

BOSS Support Centre

Centre for Development of Advanced Computing ,

Vellayambalam,

Thirunananthapuram 695033

Ph: 0471 – 2314412

BOSS Support Centre

Centre for Development of Advanced Computing ,

Campus of Pune University

Pune 411 007

Ph: 020 - 2564093

-----------------------------------------------------------------------------------------------------------------------

BOSS Support Centre

Centre for Development of Advanced Computing ,

2nd Floor, Delta Chambers,

Ameerpeth, Hyderabad 500 016
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Ph: 040 - 231050115

-----------------------------------------------------------------------------------------------------------------------

BOSS Support Centre

Centre for Development of Advanced Computing ,

Gulmohar Cross Road No 9

Juhu, Mumbai 400 049

Ph: 022 - 26201488

Email: bosslinux.support@cdacmumbai.in

-----------------------------------------------------------------------------------------------------------------------

BOSS Support Centre

Centre for Development of Advanced Computing(C-DAC),

8th Floor, D South & North,

Tidel Park Ltd.,

No.4, Rajiv Gandhi Salai,

Taramani,

Chennai-600113

Ph: 91-44 - 2254 2226/27

Email : bosslinux@cdac.in
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